Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've encountered an interesting issue, and I am wondering if anyone else has experience with it.

Every time I restart my Mac, FaceTime is added back to the Dock. If I remove it from the Dock, it disappears. Restart, and it's back. I can remove other things just fine and they stay where they are, if I re-arrange FaceTime in the Dock it stays in its new position. Only when I remove it does something put it back.

Recent System Changes that might be causing it:

  • EFI Update was just installed, it seemed to start happening as soon as it rebooted from installing this.
  • XCode was upgrade from 4.0.1 to 4.0.2

Things I've tried:

  • Deleting the ~/Library/Preferences/ and rebuilt my Dock from scratch. After restarting, everything was exactly where I wanted it except the FaceTime app was added back.

(Anything else I try, I will edit and post here)

Has anyone else had problems with applications getting "stuck" in the Dock? How'd you fix it? FaceTime is neat, and I use it occasionally, but it isn't worth a dedicated spot on the Dock.

share|improve this question
up vote 2 down vote accepted

Remove them from your dock, then go under the go tab in finder to your hard drive, then to library, and then in the prefences folder find and move it to the recycle bin. Problem solved. This worked for me and I am running Lion so, hopefully it will work for you...

share|improve this answer

This could be caused if your machine is managed -- more accurately, if your machine connected to an open directory server. Or perhaps to a OS X lion server, managing your machine's preferences.

share|improve this answer
It can even be managed locally by a policy file - stranger things have happened ;-) – bmike Sep 2 '11 at 3:51

Open Activity Monitor, kill the "apsd-ft" process, remove FaceTime and then install it again.

There's also another solution I found on google (link here):

I was able to finally fix the problem by using the option in Onyx for LaunchServices rebuild. No more Facetime icon on reboot.

share|improve this answer
That did not resolve my issue. Removing FaceTime altogether and restarting resulted in a "?" appearing in the Dock, and rebuilding LaunchServices did not do the trick either. The application isn't running when I boot, it's just been "Kept" in the Dock. – vcsjones May 8 '11 at 4:47
This is very odd indeed. Sorry I couldn't help you. – Rodrigo Sieiro May 8 '11 at 4:56
My issue was similar to this. Thanks for the push in the right direction. – vcsjones Sep 5 '11 at 3:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.