Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to fix the WiFi on my friends iPhone 3g. It sees all the networks, but I only get "Unable to join network " when I try to connect. So I jailbroke it ;) and installed WiFiFoFum just to see if I could get some more details. And it seems like the phone cycles the wifi drivers or something.

When WiFiFoFum scans the networks, they show up in a list. It does this once every ~3 seconds (it shows a loader when it does). But every 3 or 4 scans, all networks disappear, stay away for about 3 or 4 scans, then pop in again.

Of cource this could be a flaw with WiFiFoFum, but it's very coincidental in that case...

Any suggestions? I'm planning on going in with SSH to see if I can figure out closer what is happening. Should I look for anything special?

EDIT:

Some more info.. I have tried unsecured, wep, wpa and wpa2 protected networks, no difference.

share|improve this question

migrated from superuser.com May 7 '11 at 18:57

This question came from our site for computer enthusiasts and power users.

    
Super User is not for questions about mobile devices as per the FAQ. –  Mark Szymanski May 7 '11 at 18:19
    
I can migrate this question to the Apple Stack Exchange site for you if you'd like, but I'm not sure how they'll take questions relating to jailbreaking. –  nhinkle May 7 '11 at 18:51
    
@nhinkle: I'm sure they'll be fine, there are a few jailbreaking questions on Apple.SE that aren't closed. –  Mark Szymanski May 7 '11 at 18:57
    
@nhinkle it's not even at all a question about jailbreak... It's just mentioning it. –  Cawas May 8 '11 at 17:30
    
So I did go in with SSH. But my BSD-experience is limited, and BSD-handheld even more so :) So I didn't find out anything special. –  Christian Wattengård May 9 '11 at 13:39
add comment

2 Answers 2

Eliminate the possibility of a software problem by (first backing up and then) restoring to a clean default OS install. It you still can't connect in that state, it's time for a visit to the Genius Bar or a call to AppleCare.

share|improve this answer
    
Tried several times. No genius bar available, and the phone is out of any warranties anyway. –  Christian Wattengård May 9 '11 at 13:40
add comment

Try to reset all settings this usually works for me!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.