Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm currently trying to port all my old stuff from an old Power Mac G4 (MDD) to a newer Power Mac G5 (Late 2005). Both have gigabit ethernet and so I decided to connect the two via ethernet cable (Cat6). Both are running OS X 10.5.8.

However... I'm only getting speeds of up to about 40Mbit/s, and it's taking hours (nearly a whole day in total) to transfer about 200GB. Are there any reasons why it might be so slow, and is there any way I can speed it up?

Thanks!

:-Joe

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

You could try FireWire Target Disk Mode. Boot the source computer while holding down the T key and connect to the destination computer. The source's drive(s) will show up on the desktop and you can copy files that way.

I don't know if it will be any faster; the bottleneck could be your hard drive speeds.

share|improve this answer
    
That would be great - and it would definitely be faster agreed - but the disk I'm trying to access is not the boot disk... Target mode only seems to mount the boot drive, unless you know of a way of accessing the other drives via Target Mode? –  Jowie May 9 '11 at 8:25
1  
It seems to depend on the model. My MacBook Pro will share the DVD drive over FWTDM, but my iBook G4 doesn't. –  CajunLuke May 9 '11 at 13:50
    
Do they automatically show up if it's supported? If so then it's not supported on my Power Mac G4. –  Jowie May 9 '11 at 14:16
    
@Joe I believe they do automatically show up (in my MacBook Pro's case, a DVD had to be in the drive). –  CajunLuke May 9 '11 at 16:51
add comment

I already have this problem in the past and solve it by disabling internet sharing. I don't know why disabling internet sharing speedup bandwidth but it maybe useful for you.

You can also try another ethernet cable.

share|improve this answer
    
I've tried multiple ethernet cables and they all produce about the same result. Also I don't have Internet Sharing switched on. :( –  Jowie May 9 '11 at 8:26
    
Try login to your session with shift key down (to prevent some automatic app launch), check odd launched app in activity monitor and kill them. Start again your file transfer. –  Bil_fr May 9 '11 at 8:40
add comment

Considering they're older Macs, you're probably hitting the hard drives' I/O limit.

share|improve this answer
    
I wondered if that was the case, but I'm not entirely convinced... Running Xbench shows that the drives average at about 20MB/sec (going all the way up to about 80MB/sec) - I'm assuming that's also bytes and not bits. Duplicating a 50GB folder containing thousands of files locally takes about 25 minutes. But I guess it could have something to do with a network bus speed or something? –  Jowie May 9 '11 at 8:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.