Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use second monitor on my macbook. When I open some app in fullscreen, and then close the lid, the OS X exit fullscreen mode on plugged monitor and move all windows to it. How to prevent this behavior?

share|improve this question
    
are you using mirror mode or split –  Buscar웃 Jun 22 at 8:45
    
I'm using split mode –  Quadroid Jun 22 at 8:50

1 Answer 1

Disable extended desktop

By default the system will attempt to use both the external monitor and internal display in a dual-display setup; however, you can force the system to only use one display with a custom boot argument PRAM setting . To do this, open the Terminal utility and run the following command:

sudo nvram boot-args="iog=0x0"

Following this command, restart the system and your system will now either use the internal display, or only use an attached external display. To revert this setting, you can either reset the PRAM or run the following command to clear this value from the boot arguments (reboot for the change to take effect):

sudo nvram boot-args=""

Source:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.