Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I did the direct jump from Snow Leopard to Mavericks and there is possibility that I have missed some changes in the versions in between. Nonetheless, here is my problem:

When I open a document (e.g. an image) preview shows up and does its job. The problem is when I press the close button in the finder, the Preview is closed completely. In 10.6 Preview would remain open, indicated by little white dot bellow its icon in the dock. How can I keep Preview open and let it close only if I send a cmd+q?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

You need to disable Preview's automatic termination.

defaults write com.apple.Preview NSDisableAutomaticTermination -bool TRUE && killall -HUP Finder

This is due to Lion's automatic termination which was introduced so that apps which have no windows open and are not performing a task can be quit to save system resources. Generally it's good to leave on, but if you really want to disable it, use the above command.

You can disable automatic termination in all apps by setting it in the global preferences.

defaults write -g NSDisableAutomaticTermination -bool TRUE && killall -HUP Finder
share|improve this answer
1  
Thank you! You may want to add a killall Finder is necessary. As a comment, I think it's a good idea to do so for system resources, however, Preview is that one application which is going to be used every few minutes. Instead it seems it is the only application that is having this behavior. –  Pouya Jun 6 at 17:10
1  
@Pouya Yep, forgot that—added, thanks! –  George Garside Jun 6 at 17:51
    
Nice tip. Is it documented by Apple somewhere ? Is there a way to disable automatic termination for all apps ? –  Nicolas Barbulesco Jun 6 at 18:54
1  
@Nicolas Maybe, haven't really looked. Added a command for global disabling. –  George Garside Jun 6 at 19:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.