Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've got a 2009 iMac (Intel Core 2 Duo) and I've noticed that the disks never sleep. I ran a power monitor and the iMac is using a third of our electricity every day!

I've checked via pmset that hibernatemode is set to 1 and when I purposefully click Apple > Sleep the iMac sleeps by saving state to RAM. However, if I just leave the device the screen sleeps but the disk never does.

I've unplugged all USB devices and made sure that bluetooth is not allowed to wake the device and that wake-on-lan is off

maxi:~ pauldambra$ pmset -g
Active Profiles:
AC Power        -1*
Currently in use:
 hibernatemode  1
 halfdim    1
 womp       0
 sleep      2
 powerbutton    1
 disksleep  2
 hibernatefile  /var/vm/sleepimage
 ttyskeepawake  1
 autorestart    0
 displaysleep   1

I'm pretty new to Macs and Unix so I'm not really sure how I go about checking what is keeping the disks awake (or indeed if I've understood how disksleep works on a mac)

Many thanks in advance

Paul

share|improve this question
    
What version of OS X are you running? Is the iMac still in its stock configuration (no HDDs replaced)? How do you know that the disks are not sleeping (apart from a higher power consumption, which may be due to something else)? –  Austin May 2 '11 at 19:42
    
Also, this may be a silly suggestion, but try setting "disksleep" to 1 or 3. Right now "sleep" and "disksleep" are both set to 2 minutes, so perhaps the sleep occurring at the same time is interfering somehow? –  Austin May 2 '11 at 19:43

2 Answers 2

up vote 2 down vote accepted

Your iMac should automatically spin down its disks and go to sleep.

Use the following command to view a detailed log showing your iMac's power history:

pmset -g log

Look out for applications that may be keeping your Mac awake and active. Applications and other processes can keep your Mac awake if they are providing a service, such as file sharing or remote access.

Do you have an active ssh session or terminal session running? This can also be responsible for keeping your iMac awake.

Be aware that Apple does not officially support hibernation on desktop Macs. Your setting hibernatemode suggests you have this feature enabled.

Disclaimer: I am involved with a commercial product called Power Manager, it can help make your Mac sleep more predictably.

share|improve this answer

Sleep can be a tricky thing, Mac OS requires that there is no disc activity for a full minute after the time you set it to sleep. So somethings you may want to check is if the issue happens in Safe Boot, or if there is anything spewing into your log and finally if the issue persists in a new user account.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.