Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When i try to open a specific project in xcode (i can open my other projects just not the most important one) i get this error

error

I have gone in "Get Info" and made sure my account had complete access, but i still get this stupid error and i have no idea why. I am also the administrator for my computer and logged into my only account for this computer (i have not made multiple accounts) Can someone please help. - Thanks

share|improve this question
1  
I am not sure, but if xcode projects are bundles of files you may have permissions to open the top level directory but not the subsequent subfiles and subfolders. Try chmod -r 777 /Users/username/pathtoproject file, and see if that allows you to open it. –  hobs May 1 '11 at 16:35
1  
i ran your terminal command but it didnt open the project. and the only options i found under the gear were to "reverb changes" –  luca590 May 1 '11 at 17:00
1  
Questions about programming tools should be off-topic, basing on the FAQ, with the exceptions reported in the FAQ. –  kiamlaluno May 1 '11 at 21:50
5  
@kiamlaluno I appreciate your vigilance about off-topic questions, but in this case it seems like XCode is incidental to the question - this question seems to be more about file permissions, and would likely be closed on Stack Overflow, so I'll allow it to stay. –  Kyle Cronin May 1 '11 at 22:15
1  
@luca590: Where is the project located? On an internal hard drive or an external one. I'm thinking that if the project is on a server share, that may be the cause of the problems. –  Philip Regan May 2 '11 at 14:46
show 8 more comments

1 Answer

up vote 1 down vote accepted

Open terminal and type

sudo chmod -R 777 /path/to/project_folder

NOTE: the capital R in the command above. Obviously change the path to your project folder to what it actually is.

If that command works without error, but you still cannot open the project, then it isn't in fact a permissions problem but another bug in XCode.

You're not the first person to report this error however. Hopefully the above sorts it out for you. Let me know.

share|improve this answer
    
its giving me this sudo: illegal option -- R –  luca590 May 3 '11 at 1:44
1  
did you type sudo -R or sudo chmod -R etc as per my answer? –  RobZolkos May 3 '11 at 2:39
    
ok it let me in. How did u do that? –  luca590 May 3 '11 at 13:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.