Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Recently, I've noticed that my MacBook Pro 5,1 (mid 2009) running Snow Leopard 10.6.6 doesn't respond when I press CTRL+3 or CTRL+4.

When, for instance, I'm in an application that has no bindings for the CTRL-keys and I press CTRL+2, I will hear the OS X alert sound, because the application receives a key combination it doesn't understand. This is the case for all CTRL+n combinations, except 3 and 4.

No matter where I try it — even in places where pressing the aforementioned key combination would have an actual effect — nothing happens.

But it doesn't just seem to ignore the keypresses; it numbs the keyboard. If I, for instance, hold CTRL and press 5 and 6, I will hear two alerts. One for each unknown key combination. If I then do the same, but with the numbers 4 and 5 (which usually are responsive), there's no sound. In fact, no matter what key I press when CTRL is being held down after having pressed 3 or 4, nothing happens.

At first I figured I probably added some shortcut to the key combinations by accident, but I can't find it anywhere. In System Preferences → Keyboard, I've restored everything to default, but that didn't seem to change anything.

I've tried with both the onboard keyboard, a wireless Apple bluetooth keyboard and a cabled USB Apple keyboard.

share|improve this question
1  
Try activating Spaces (the default 2x2 arrangement of spaces is fine), then pressing Ctrl+1,2,3,4. You should move to a different Space each time- does this work when you hit Ctrl+3 and Ctrl+4? –  matthias May 1 '11 at 0:35
    
@matthias: Yes, CTRL+3 and CTRL+4 works perfectly with Spaces. It must be some shortcuts I've defined that Spaces is overriding, but I have no idea where. –  kba May 1 '11 at 2:41
add comment

2 Answers

up vote 3 down vote accepted

I think this is a bug in Mac OS X and has something to do with the way the keyboard shortcuts for Spaces are processed. Try this:

  • Make sure Spaces is turned on in the System Preferences with the standard 4 spaces layout, and standard key combination for switching to a space.
  • Open a folder in the Finder.
  • Press and hold CTRL, and press any of the number keys. If you press 5, 6, 7, 8, 9 or 0 first you will get a beep. Same if you press one of those keys again (still holding CTRL). If you then press 1, 2, 3 or 4, you will switch to that space number; or just stay in that space if you were already in it. If you then press any of 5, 6, 7, 8, 9 or 0 again, it won't beep anymore.

If you simply turn off Spaces, the above won't happen and whatever order you press the keys in, they will continue to beep. If you change the number of spaces to only two, then 3, 4, 5, 6, 7, 8, 9 and 0 will give you a beep until you've pressed either 1 or 2. I don't know of an application in which those keys have a non-Spaces functionality and would do something useful other than beep, so I haven't been able to try what happens in such an application. In any case, I don't think you need to worry there's something wrong with your keyboard or the way you've configured the keyboard bindings; it seems to be a bug in Mac OS X.

Edit: Try the above in a new folder in which you've created folders named "1", "2" and so on. I find the Finder's behavior in this case somewhat strange: if you press CTRL-8, it will beep yet also switch the selection to the folder named "8". But again, pressing 5 through 9 will neither beep, nor change the selected folder once you've pressed any of 1 through 4.

share|improve this answer
    
The thing is I need to be able to use CTRL+3 and CTRL+4. But after I tested what you wrote about Spaces and I fiddled a bit with the settings in the Exposé & Spaces preference pane, it's suddenly gone. I suspect that some settings were screwed up last time I did a System Update. I tried to change the "To switch directly to a space" from "^ Number Keys" to nothing, and then back. This seemed to fix the problem. Somehow the "^ Number Keys" were reserved for Spaces, even though Spaces wasn't enabled. Thanks a lot! –  kba May 1 '11 at 14:29
    
I hadn't noticed this, but I had a similar thing on my system. The Spaces shortcut keys CTRL+digit worked for switching to a space even though in the System Preferences the shortcut key setting was set to "-". I changed it to "^ Number Keys" and then back to "-" and then they really were disabled. Thanks for pointing that out. –  Rinzwind May 1 '11 at 16:08
add comment

I realize this is an old question but I had the same issue of unresponsive Ctrl+3 and Ctrl+4 keystrokes using OS X 10.8.4 and found a solution that worked for me using information from this answer.

  1. Open ~/Library/Preferences/com.apple.symbolichotkeys.plist (I used XCode).
  2. Update keys 120 and 121, which represent the Ctrl+3 and Ctrl+4 keystrokes respectively, switching enabled to NO for both.
  3. Restart your computer.

Hopefully this helps someone else out there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.