Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've bought a 15" MacBook Pro Retina Late 2013 and so far everything works perfectly. Luckily I'm not experiencing the "Lose Wifi after sleep" issue.

That said, I only rarely connect to high-bandwidth WiFis. I'm currently working with a colleague from his home office. He has a Netgear router capable of 802.11n and his MacBook Pro (also Retina, but not late 2013, so he doesn't have the ac card) connects using 802.11n and 2.4GHz on channel 1 without a problem. My MBP however connects on the same channel using only 802.11g which is pretty slow when we want to transfer files.

The WirelessDiagnostics report shows I connected to a 5GHz 802.11n yesterday when we were at the client's office.

What can I do to fix or at least diagnose the problem? Is it just Mavericks, or a driver issue with these new ac cards?

share|improve this question
It's happening the same to me. Look this thread: – naiad May 25 '14 at 10:38
Yeah I think it's a driver issue, because it can connect to some 802.11n networks. Haven't measured Ethernet yet, but it seemed fine when I copied some stuff. – Marius Soutier May 25 '14 at 10:43

1 Answer 1

I had the same problem with my rMBP 15" late 2013. Like Exact same problem. Apple is terrible at quality and consistency control in making drivers.

Intall this older kext(wifi driver) and it will fix your problem. I can connect to N only networks on 2.4 and 5 ghz and get 300 mbps transmit rates now.

Here is what I did to get the WIFI working as described above.

  1. Go to you hard drives root folder. Open system/library/extensions drag & drop the IO80211Family.kext to a new folder on your desktop(as a backup) then delete it from system/library/extensions

  2. Download & Run Kext Wizard

Direct download-->

  1. Download & Extract - IO80211Family.kext zip. Here are two links incase one goes down

  1. In Kext Wizard click install tab then then Drag & Drop the extracted IO80211Family.kext file into the Kext Wizard, Then click Install button.

  2. Click the Maintenance tab and check the S/L/E box to repair permissions & Rebuild Cache.

  3. Restart and adjust your router settings to N only and test. Should fix it. If it breaks wifi(99.5% chance it wont) or makes it worse then repeat these step and reinstall the original Kext that you backed up in Step 1.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.