Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I cannot log into FTP sites on my iMac (Intel Core i5, 2.8GHz, running OS X 10.6.7).

I probably created the problem when I installed Firefox and it took over as the default browser. I changed the default back to Safari, but then every time I try to log into the FTP at school (ftp://sws.pcc.edu), Firefox launched instead. I found a utility that said it would allow me to control internet protocol associations, which it kinda did. I tried to set Safari back to FTP but now FTP's open in Finder.

How do get things back to allowing me to login to FTP sites in Safari?

share|improve this question
add comment

4 Answers

Safari does not support browsing FTP sites (displaying directory listings). Given a ftp: URL for a specific file, it will display or download it, but URLs for directories will be passed to the Finder instead.

share|improve this answer
add comment

Try this freeware app called MisFox. It will allow you to change the protocol helper for FTP.

share|improve this answer
    
Well, that helps in that it keeps it from feeding the FTP into Firefox, but now it is launching the FTP in Finder. Closer, but not quite the complete solution. Is there perhaps something I am missing here? Thanks for the tip so far. –  Leslie Martin Apr 28 '11 at 4:11
add comment

Navigate to ~/Library/Preferences/com.apple.LaunchServices.plist.

Open the file up in a text editor (any will do) - if you have Property List Editor installed, I'd still recommend a text editor, as it makes the next step easier.

Do a quick find in the document for "ftp" - once you've got the entry, it should look something like this (I've removed the opening < brackets from the example, because the formatting strips them out:

dict>
key>LSHandlerRoleAll /key>
string>com.panic.transmit /string>
key>LSHandlerURLScheme /key>
string>ftp /string>
/dict>

For me, Transmit is set to handle FTP. Change that line to com.apple.safari, save the file, and give it a shot. Make a backup first. Hope this helps.

share|improve this answer
add comment

My question is similar, but slightly different, and I hope someone can help. I don't want ftp links to open in Firefox, either. I want them to open in my FTP program (in this case, Transmit), and MisFox did precisely that! Thanks for the suggestion.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.