Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Now I had a problem with my keyboard.

When I press shift and number keys, the output is different than expected.

When I press Shift plus 2, it gives me "

when I press Shift plus ;, it gives me +.

when I press [, it gives me @.

All the symbols are strangely mapped. I thought something was wrong in the keyboard routing or processor. I checked system preference -> keyboard:

Here is what I see;

enter image description here

So strange! Apple recognizes the wrong mapping but continues it! I want it back to normal mapping.. Is there any way to do it or actually create a software mapping so that SHIFT PLUS 2 is @ ?

Thanks Indeed this layout belongs to a Japanese Layout, obtained from http://support.apple.com/kb/HT2841: Now the question is how to remap it back to a US layout..

enter image description here

share|improve this question
    
When did it start. Did you install any software or fiddle with system settings that started this problem? –  Joop Apr 29 at 8:19
    
What are your language settings? It sounds like you may be using a different keyboard layout for your hardware keyboard –  stuffe Apr 29 at 9:42
    
@Joop no I didnt do anything to the OS. I did installs a new piece of keyboard .. –  bboczeng Apr 29 at 15:04
    
@stuffe I actually deleted the pinyin and everything is the same . It's more related to hardware. When I use external Bluetooth keyboard , everything goes to fine immediately –  bboczeng Apr 29 at 15:05
    
You've tried hitting the "Change Keyboard Type..." button in the Keyboard pane of Keyboard Prefs? –  Wayfaring Stranger Apr 29 at 17:04

2 Answers 2

up vote 3 down vote accepted

Your mac for some reason thinks you are using a Japanese JIS hardware keyboard instead of the US ANSI or European ISO. Notice the Yen key at top right. What kind of keyboard do you actually have? This note may help:

http://m10lmac.blogspot.com/2009/12/fixing-keyboard-type-problems.html

share|improve this answer
    
Hi: thanks. I am indeed installing a new piece of keyboard I bought from eBay claiming it is authentic US. The layout of the keyboard is US too but the mapping is wrong. I wonder if there is a way to modify or bypass this wrong mapping in software means? Thanks! –  bboczeng Apr 29 at 15:07
    
Will try it today and let you know. Thanks! –  bboczeng Apr 29 at 15:08
    
I want to add to the answer. Try scripts.sil.org/cms/scripts/… and I managed to change the default layout of the keyboard –  bboczeng Apr 29 at 22:57

It might be this since you have the second input set as Pinyin-

Automatically switch to a document’s input source

Choose an input source for a document and have it used every time you work in the document until you close it, even if you switch to other documents that use other input sources in the meantime.

This option appears only when you add a second input source.

Chinese input sources (such as Pinyin-Simplified or Pinyin-Traditional), Korean input sources (such as 2-Set Korean or HNC Romaja), and Japanese input sources (such as Romaji, Hiragana, or Katakana, grouped in Kotoeri) include numerous options. If you added one of these input sources, switch to it, then open and search its help to learn about the options.

share|improve this answer
    
But choosing pinyin does not change the layout like this. Try it for yourself. –  Tom Gewecke Apr 29 at 12:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.