Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When using QuickLook to quickly look through multiple images (pressing space and then using the arrow keys to navigate), some images will not get displayed by QuickLook when hitting them up a second time (going back for example).

A GIF does a much better job than me showcasing the issue. So here's me previewing a few random images:

screenrecording

I have tried deleting

~/Library/Preferences/com.apple.QuickLookDaemon.plist ~/Library/Caches/com.apple.QuickLookDaemon/Cache.db ~/Library/Caches/com.apple.QuickLookDaemon32/Cache.db ~/Library/Containers/com.apple.quicklook.ui.helper

and restarting, unfortunately to no avail.

Repairing permissions and restarting the Finder in 32-bit mode, as suggested by others, don't appear to have any effect on this issue either.

This happens with all kinds of images, no matter their source or format.

share|improve this question
    
I have the same problem. OS X 10.9.2 did you fix it at the end? –  GianPaJ Jun 10 '14 at 23:52
    
Unfortunately nothing so far. At the moment I'm almost hoping it won't bug me enough until switching to Yosemite later this year, but that's hardly a solution. –  Kilian Koeltzsch Jun 11 '14 at 8:28

7 Answers 7

up vote 15 down vote accepted

This "blank Quicklook image" Bug is caused by the activation of the undocumented TextSelection-Feature. As soon as I deleted that feature with this terminal command the blank images were never seen again ;-)

defaults delete com.apple.finder QLEnableTextSelection; killall Finder;

If this delete-command doesn't work for you, you could try to disable the feature with

defaults write com.apple.finder QLEnableTextSelection -boolean NO; killall Finder;
share|improve this answer
    
Amazing stuff! It's a shame to lose the TextSelection feature, but this is worth it. Thanks! –  Kilian Koeltzsch Aug 3 '14 at 11:15

A temporary solution is to press ALT (twice) when presented with a grey image.

share|improve this answer
    
Whilst this is not a solution, this is a pretty damn awesome workaround. Thank you for this! –  Kilian Koeltzsch Jun 17 '14 at 11:46
    
Thank you, a million times. –  palaniraja Jul 10 '14 at 6:06

This might be some kind of rendering bug due to switching between images 'too fast' for the Mac to handle. In theory it could be due to the filesize and/or image dimensions that makes it a bit harder to render the images fast enough when scrolling through them quickly. Although they should be cached for a little while after viewing them so I wouldn't think this is the case.

I read here that there has been an occuring problem with Mavericks and QuickLook since the start and apparently it's not fixed yet. Hopefully some of the tips listed in that link is somewhat helpful for you. I'll google some more and edit this comment if I find something else of interest.

share|improve this answer
    
Thanks for the link, but unfortunately none of the mentioned solutions seem to be able to help :( –  Kilian Koeltzsch Apr 26 '14 at 22:45

I wasn't able to simply delete the file to fix the problem. I had to go into my back up account and make a copy of the file from ~/Library/Preferences/com.apple.finder.plist and then move it into my user account. I'm sure you could do the same thing with your Guest User account, too.

For me, the problem was caused by making the text in QuickLook copyable. I noticed when I turned on defaults write -g QLEnableTextSelection -bool true that the blank Quicklook bug was coming up as talked about in this thread. When I turned it off, (defaults write -g QLEnableTextSelection -bool false) the problem went away.

share|improve this answer

Used OnyX to turn off "Turn on Text Selection in Quick Look" under Parameters > Finder > Misc. options:

Works great. Been trying to figure this out for a while. For some reason the command line didn't work for me.

share|improve this answer

I'm using Yosemite. Tried all those approaches above, but they didn't last for long. But I did find one approach that DID work. Hold down the Option key before pressing Quick Look (the icon will change). The pictures will go to full screen. Then it won't fail to display. Press Esc to quit.

share|improve this answer

I have found the solution. I have Yosemite and none of this terminal line solutions worked for me, neither using Onyx.

Looks like Yosemite added native quicklook support for animated gifs. Just go to your library and delete the quicklook file you installed. Read N15h0 on answer 15 to get the procedure right.(on the bottom)

http://www.quicklookplugins.com/2009/10/01/animated-gif/

share|improve this answer
    
Sorry, but the question/issue has nothing to do with gif images. No custom quicklook file was installed. –  Kilian Koeltzsch Apr 19 at 18:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.