Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using my Mac to connect to an Active Directory drive.

When I was running on Leopard, it worked fine : I could open, modify and save files from the remote drive.

Last week I upgraded my computer to Snow Leopard (10.6.7) and since that, I'm having problems : I still can connect to the remove drives, I can open files, but when I want to save them I get the following error : "The document mydoc.txt could not be saved."

But if I do Save as and save the document under the very same name, then, it's working !

I have no idea what's wrong ! I tried to disconnect from the domain and reconnect, but I still have the problem.

share|improve this question
    
Do you have an ACL on that folder? –  tegbains Apr 26 '11 at 23:04
add comment

2 Answers

I found a workaround to the problem :

The path to the document was the following :

smb://srv-fichiers1/Personnel/myhome/mydoc.txt

The problem was that I didn't have read/write access to the Personnel folder.

The administrator added read/write access to this folder and now, everything is working fine.

I agree that this is more a workaround than a real solution, but it does the trick for me !

share|improve this answer
add comment

I saw this posted on a Mac and Windows interop site, Snow Leopard and Active Directory Tips and Reports Try the following from the article:

Solution: In a long session of trial and error, I tried saving to the administrative C$ share on my Windows 7 desktop, which was owned by "NT SERVICE\TrustedInstaller". Creating a share on Win 7 had the same error behavior as before, when the shared folders owner was changed to TrustedInstaller, it worked fine. The following challenge was to port that solution to a XP/2003 environment, which doesn't have that account. My boss, out of a leap of logic, tried the "NETWORK SERVICE" domain account as the owner of the folder on 2003, and everything works. Obviously the sharing/ntfs permissions have to be set properly on top of that. I'm sure I'm not the only one that's had this problem, so I figured I'd toss it at you guys.

Weird.

share|improve this answer
    
thanks for the answer. I tried the solution mentionned, but the problem remains. –  Jérôme Apr 28 '11 at 7:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.