Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My bank uses "smsTAN", so when I make a transfer, the TAN gets texted to me. I would like to prevent texts from my bank from appearing in the lock screen as this lowers the safety of this method (someone would just have to nab my phone and find out my five-letter online PIN, don't ask me why my bank still enforces five-letter PINs).

I'd like to keep my other texts appearing in the lock screen.

share|improve this question
I do not see how that could be a problem, since the TAN gets changed/created only when you request transfer, and is no longer valid after that. – Buscar웃 Apr 23 '14 at 10:35
@Buscar웃 The TAN may be unique and not used again, but often times smsTAN sends some transaction information along with it. – 0942v8653 Apr 23 '14 at 11:09
@0942v8653 there is a answer to this question already, I do not use that method since none can do anything with the smsTAN info other then the originator, by logging in to the bank again and entering the TAN to approve the transaction. – Buscar웃 Apr 23 '14 at 11:48
@Buscar웃 If somebody knows my banking PIN they only need my phone, not my phone PIN to be able to generate new smsTANs. – Ruben Apr 23 '14 at 14:07
@Ruben If someone knows your Banking PIN then you are in trouble already. But you are right, they would need 1- your Banks login information, 2- your phone to use the TAN to transfer money to they account? Wait.... then they would disclose they account and that is traceable ? hmmm. – Buscar웃 Apr 23 '14 at 14:25

Although excluding specific contact's text from being shown on the Lock Screen is not possible, you could always switch off the Show Preview option. Therefore a notification of your bank will be shown, but no portion of this message will be previewed, safeguarding your five-letter PIN.

To do so just go to Settings / Notification Center / Messages and turn off Show Preview.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.