Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have had a rather embarrassing bug for a while now. It has to do with safari on my iPad and adult websites. After every visit to one of those websites, I always clear my browser history. However, one page just sticks in my suggested websites. I only have to type in an "X" or a "W", and it pops up in the suggested websites, like shown here, even though I have cleared my history.

If anyone knows a solution to this somewhat embarrassing problem, I would be very grateful.

share|improve this question
    
Besides your issue, won't using Private Browsing be a better option than clearing your cache / history every time? –  Thecafremo Apr 23 at 10:05
    
It indeed seems to be a better option, and I will most definitely do this every time I want to walk the dog. However, this doesn't change the fact that my iPad has been "marked" by this "tag", and as of such I am eager to find a solution. –  Toby van Kempen Apr 23 at 11:16
    
Indeed. I was just making sure that you were aware of this other option. –  Thecafremo Apr 23 at 11:34
    
Does signing out of iCloud and clearing the history solve the problem? –  sayzlim Apr 23 at 16:54
    
Signing out of it on the iPad? –  Toby van Kempen Apr 24 at 7:05

1 Answer 1

Note that if you use iCloud on a Mac and your iPad (or other iOS devices) (the same account), open tabs will appear on the iPad and vice versa in the iCloud Tabs section (next to bookmarks on iPad). This could be where such a suggestion is coming from. I would suggest clearing history and cookies/data on all devices using iCloud (yes you will lose logged in state for many sites and will need to re-sign in).

On your iOS devices, make sure you are clearing your history and data using the Settings app, and not by manually deleting entries in Safari's bookmark menu. You can also disable Safari with iCloud using the Settings app under the iCloud section.

After you have reset everything, when you want to visit sites and not keep history, you can use Safari's privacy mode. To do this in Safari (iOS 7), when you tap the address bar, tap Private above the keyboard on the left side to toggle privacy mode. If you are using a physical keyboard, this option will still show at the bottom of the screen.

I use Chrome as my main browser on iOS. There you tap the button on the top right (next to the address bar most of the time) and then tap New Incognito* Tab to enter incognito mode.

Clear history

Clear cookies and data

share|improve this answer
    
I tapped both "Clear History" and "Clear Cookies and Data" in the settings, but to no avail. Therefore I conclude that the problem must lie within the iCloud issue. I will try erasing my browser history and cookies on my laptop as soon as I can access it. –  Toby van Kempen Apr 23 at 9:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.