Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an iMac and a MacBook running Snow Leopard.

I used to connect from my MacBook to my iMac regularly with screen sharing. Has worked great for over a year.

I recently got my hard drive in my iMac upgraded (from 250GB to 1TB), as far as I know the technician somehow "cloned" the drive, but I really have no idea what the process is. All I know is the iMac works exactly as it did before, it now has a bigger drive, except that screen sharing no longer works.

There were two "admin" accounts on the iMac. "rob" and "user" (user was created by the technician during the hard drive upgrade.

When I connect via screen sharing with "rob/correctpassword" it says something like "connect failure, can't verify password". As a work around I would try "user/blankpassword", same error, then try again with "rob/correctpassword" and it would work. I had to do this same thing every time to connect. Rob-fail, User-fail, Rob-success.

Eventually I deleted the "user" account because I never used it, and now I can never connect as "rob". Screen sharing is on, and like I said, this always worked before, but there's an authentication error every time.

Does anyone have ideas what's wrong, or suggestions for how to fix this?

share|improve this question
Could you elaborate / edit the question. Are you storing passwords in the keychain? Did you reset the VNC password assuming you are using normal finder / Apple default screen sharing. – bmike Apr 25 '11 at 19:10
Hi bmike, I'm just using whatever the default Apple "share screen" functionality is. No VNC-specific stuff. Also, I don't tend to use "remember my password" style functionality, and I don't specifically use the Keychain. Does that help? Sorry I didn't add/edit the original question as I don't think there's new info to add. Hope this helps. – rhume55 Apr 25 '11 at 22:47
Excellent. That helps greatly. The default relies on VNC sharing enabled with a VNC password as well as allowing it for all users or your specific user in sharing preferences. Problems with the user, the network, or the system can break things as you describe. I'll post an answer to list these in more detail. – bmike Apr 26 '11 at 17:28

Things that have helped me with isolating the failure and eventually getting screen sharing working again:

  1. isolate the network - turn off WiFi and connect the two machines with one ethernet cable. This eliminates ports (other than internal firewalls), DNS, and network issues from mis-routing the traffic.

  2. Turn off screen sharing and remote management and set it up again changing the password to be sure the new password and sharing permissions are set for all users or your specific user.

  3. Watch the logs in console app - the bonjour daemons, screen sharing daemons and network errors are all logged so you might get a clue if a program is having problems accessing a keychain or other issue
  4. Add in a new user to isolate the desired user's preferences and files - it could be something corrupt in the desired user and you won't catch that unless you make a new account to isolate that potential cause.
share|improve this answer

I have an identical set-up to you and Screenshare all the time. Here is what I've discovered that can stop Screensharing working (I have to reboot my router to fix these issues)

(1) If I can see my iMac from my MacBook under the Shared tab (on the MacBook) and the device is identified as 'iMac', then Screensharing works. If the iMac shows up as 'imac' then Screensharing doesn't work. (Server address is afp://iMac.local when I check under Finder>Go>Connect to server when everything is working)

I've just assumed there's a bug in the Linksys router that occasionally causes the problem, and I suppose a quick reboot fixing the problem is easier that discovering the real cause and fixing it once and for all.

I should add that even when I can't Screenshare both the MacBook and iMac continue to have internet access: it's just that they can't talk to each other, which sounds like a device table problem in the router to me.

I use the same fix if I attempt to Connect to the iMac by double clicking iMac under Shared on the MacBook, and then clicking the Connect button. If the router is working then I get the Connect authorization dialog into which I put the login name and password for the iMac. If the router doesn't want to connect me, I reboot the wretched thing and away we go.

You may have your accounts and passwords screwed up. If you are the admin and you can login without a password, then the Connect dialog can be responded to with just your login name. Revisit the Account setup in System Preferences.

Sorry this is a bit rambling.. it's late here and I'm tired! Best of luck

share|improve this answer
Thanks for the feedback! Hopefully some of that will help. – rhume55 Apr 26 '11 at 2:43

Sometimes when drives get cloned over their permissions files can get messed up. I would recommend a) resetting the vnc password in system preferences. and b) checking your permissions using disk utility. Don't be alarmed if a lot of them are wrong, they're easily fixed

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.