Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a flaky keyboard which sometimes translates a single keystroke into several, and while I hope to repair it soon, I am wondering if there is a software solution which would help for the time being. For example, it could notice that a single key is being repeated too fast for a human to produce and filter out the bogus key events.

Does such a program exist?

share|improve this question
1  
This could also be an accessibility issue as well, good question. support.apple.com/kb/TA26508?viewlocale=en_US –  hobs Apr 25 '11 at 15:18
    
@hobs, that prompted me to look into the Slow Keys feature in Universal Access. Unfortunately, it seems that it doesn't actually filter out the duplicate key events unless I set the threshold high enough so that normal typing is too fast and keystrokes are lost. Also, with that feature on, key repeat rate becomes incredibly slow. –  Reid Apr 25 '11 at 18:21
    
Sorry I couldn't be more help :( –  hobs Apr 25 '11 at 22:37
add comment

3 Answers

Have you tried setting the Key Repeat Rate in system preferences to Slow? This may help with your problem.

share|improve this answer
1  
Well, it's not key repeat rate, it's the fact that a couple of the keyswitches are flaky and sometimes give multiple key events for a single physical key down. This is before the key repeat kicks in. –  Reid Apr 25 '11 at 18:10
add comment

You could use the built in Text Replacement and change ss to s, aa to a, etc. Fairly time intensive and doesn't really allow a good input of double characters, you would have to right click and uncheck substitution to type the word egg.

share|improve this answer
    
Hmm, that's a good idea. Unfortunately, it doesn't quite work: the substitution appears to happen only when the repeated keys are an independent word, and it doesn't address the issue of when the repeated key is mixed with other letters (e.g., "addrerrss", which just happened actually - it's the R key that's bad). Thanks though! –  Reid Apr 25 '11 at 18:28
    
Damn. I guess its time to get a new keyboard haha. –  hobs Apr 25 '11 at 22:38
add comment

There's a setting called Slow Keys, in the Universal Access panel of System Preferences. It appears to add a delay to prevent people with shaky fingers from typing repeated keystrokes. Looks like there is some speed adjustment settings but I've never used it before. This is different from the key repeat setting in the keyboard panel.

enter image description here

share|improve this answer
    
Hi @Niloc, thanks - but see my comment posted earlier. :) –  Reid Apr 25 '11 at 21:51
    
Sorry missed that comment, think it might have happened nearly the same time, I suspected that it might force you to reduce the speed of typing too much. Good luck fixing the keyboard soon though. –  Nilloc Apr 28 '11 at 15:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.