Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've already asked this question on ServerFault, but I'm beginning to think that this might be an issue more with my OSX client machine than our SMB server.

I'm using 10.9, but this problem happened when I was on 10.8 as well. When I first connect to our SMB share (hosted by some recent-ish windows server, not linux or osx server), the Finder seems to lock up for a good 30 seconds while it fetches the root folder of the share. Navigating the share is extremely slow at first as well - it takes about 30 seconds to open each folder. In the system log, I see this message repeated many times:

Apr  9 15:14:37 teds-mac-mini.teradici.local NetAuthSysAgent[2139]: smb_mount: mount failed to teradici.local/data, syserr = Permission denied
Apr  9 15:14:39 teds-mac-mini.teradici.local NetAuthSysAgent[2139]: NAHSelectionAcquireCredential The operation couldn’t be completed. (com.apple.NetworkAuthenticationHelper error -1765328228 - acquire_kerberos failed tmiddleton@LOCAL: -1765328228 - unable to reach any KDC in realm LOCAL, tried 0 KDCs)
Apr  9 15:15:11 --- last message repeated 5 times ---
Apr  9 15:15:11 teds-mac-mini.teradici.local NetAuthSysAgent[2139]: smb_mount: mount failed to teradici.local/data, syserr = Permission denied
Apr  9 15:15:13 teds-mac-mini.teradici.local NetAuthSysAgent[2139]: NAHSelectionAcquireCredential The operation couldn’t be completed. (com.apple.NetworkAuthenticationHelper error -1765328228 - acquire_kerberos failed tmiddleton@LOCAL: -1765328228 - unable to reach any KDC in realm LOCAL, tried 0 KDCs)
Apr  9 15:15:16 teds-mac-mini.teradici.local NetAuthSysAgent[2139]: smb_mount: mount failed to teradici.local/data, syserr = Permission denied

Eventually the delay in opening folders goes away and I can successfully navigate the SMB share. When the SMB share is responsive, no new messages like these show up in the system log, so I'm inferring that they're related to the problem I'm seeing.

I'm using a local account on my mac - I don't know whether its possible to log into a mac with ldap or active directory, but I'm not doing either of those. I do, however, have an active directory account here at work, and I can use that to access network resources at work (indeed, that's how I'm logging into the SMB share).

Any ideas what might be going wrong here? Is it an OSX/client issue? Could it be an issue with the SMB server? Active directory?

share|improve this question

2 Answers 2

I'm having the exact same problem on my client. Looking at a WireShark trace, there is always a 45 second delay in opening the connection the the file share (OSX Server 3.1.2). Using SMB1 (CIFS) does the same thing and WireShark confirms SMB vs. SMB2. Any other ideas out there?

share|improve this answer
    
I don't see a reason to delete this since it explains how to reproduce the issue and might lead to an answer with an edit. Parts of it could be added to the question, but let's not delete this contribution ... –  bmike Jun 4 at 17:05
    
@bmike IMO the answer is a valid comment, but doesn't directly answer the question –  grgarside Jun 5 at 18:04
    
Where is the line between moving the discussion forward and providing a partial answer or rebuttal or negative answer and non-answer. I don't see this harming the site and I do see it helping. I agree that it's not a complete answer but wouldn't case a vote to delete. (I actually up voted it in fact...) –  bmike Jun 5 at 18:09

Try forcing OS X to connect to your network share using SMB1 instead of SMB2. To do so:

  1. Open the Finder.
  2. Select Go -> Network.
  3. In the "Server Address" field, enter "cifs://yourservername" instead of "smb://yourservername".
share|improve this answer
    
Yes - I've done this and the same thing happens. cifs:// instructs OSX to prefer smb1 - do you know of any way of telling whether it actually got smb1? I suspect IT has completely disabled smb1 for other reasons (mostly their hopeless quest to make smb run as fast as our nfs shares). –  Ted Middleton Apr 11 at 6:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.