Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Is there anyway to config my Mac to don't scape characters when I copy and paste some text on the console? Could anybody help me? It is driving me crazy to erase all \ characters inserted after a simple copy and paste on the console.

Many thanks, Thiago

share|improve this question
1  
Do you mean "Escape"? Because scape is not a word. –  Fake Name Apr 23 '11 at 1:49
    
Yes, sorry, I mean escape. –  user1946 Apr 23 '11 at 11:11
    
The OP mentioned backslashes, so I assume they're talking about the escaping (which should probably be called "quoting") performed by Edit > Paste Escaped Text, in which case the answer is to use the normal Paste command instead. –  Chris Page Oct 12 '11 at 12:21

1 Answer 1

up vote 3 down vote accepted

If you are asking about pasting into windows of the Terminal application (which is not the same as Console application; neither of which are the same as the actual “console”), then you can uncheck the Escape non-ASCII input option in the “settings set” that you are using.

With Terminal active, open the preferences: Press + , or select the Terminal > Preferences… menu item.

  1. Click the Settings icon in the tool bar of the preferences window.

  2. From the list on the left side of the preferences window,
    select the “settings set” that you want to modify.

    The settings set of the previously active Terminal window will be initially selected.

  3. Click the Advanced tab.

  4. Uncheck the Escape non-ASCII input checkbox.

screenshot of Terminal Preferences window with mouse cursor on “Escape non-ASCII input” checkbox and numbered red arrows indicating steps to access the checkbox

share|improve this answer
    
“Escape non-ASCII input” does not perform backslash escaping like Paste Escaped Text. “Escape non-ASCII input” prefixes each non-ASCII character with a Control-V. In Bash and probably other shells, this “quotes” control characters, for example, so they aren’t interpreted as commands. –  Chris Page Nov 3 '11 at 3:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.