Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've upgraded git today and in its README file I found the following excerpt:

If you don't already have Tcl/Tk Aqua installed on your computer (most MacOS X installs have it), you will get this error message. To resolve it, simply go to the website for Tcl / Tk Aqua and download the latest version:

http://www.categorifiedcoder.info/tcltk/

If you have an older version of Tcl / Tk Aqua, you'll benefit from upgrading. There have been many usability improvements since the version that comes shipped with MacOS X Leopard.

I tried the link and it redirects to Daniel A. Steffen LinkedIn page, who is the lead developer of Tcl/Tk for Mac, as far as I understand. I tried googling to find alternative links, but they all redirect to the same LinkedIn page. From this I gather that either this alternative version is already included in the Mac OS X, or there is some ongoing conflict. Can anybody enlighten the situation?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Tcl/Tk Aqua is available from this page

http://sourceforge.net/projects/tcltkaqua/

This page has the latest version.

share|improve this answer
    
Pretty bizare, git documentation suggests that installing this version is advantageous, but this version is dated 2005. –  mpiktas Apr 22 '11 at 8:10

As an alternative, Tcl (beta) is now available as from ActiveState

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.