Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Suddenly my MBP shows an "Other..."-Account on the login screen. I searched for a solution to get rid of it and found a couple of answers that say I have somehow activated/enabled the root user. All I did was using a couple of trivial sudo-commands at the command-line, but nothing experimental or which I am unfamiliar with...

The suggested solutions said I need to deactivate the root user in the Directory Utilities but it was not activated.

Are there any other solutions to get rid of this "Other..."-Account?

share|improve this question

Have you tried the sudo /usr/bin/defaults write /Library/Preferences/com.apple.loginwindow SHOWOTHERUSERS_MANAGED -bool false in the terminal? This turns off showing some of the other user types.

Doing some additional research, it looks like this has been somewhat addressed in this post on http://superuser.com/questions/70156/hide-users-from-mac-os-x-snow-leopard-logon-screen

share|improve this answer
    
Although I haven't tried the command in the terminal your link pointed me to the right direction. Thank you! I installed Zend Server CE that day which created a System-User causing this problem... – user5829 Apr 19 '11 at 19:15
    
Awesome, glad to help. – ConstantineK Apr 19 '11 at 19:18
    
It perfectly worked on Mavericks. – Thecafremo Nov 5 '13 at 11:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.