Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

We have enabled Time Machine on a Mac OS X server (10.6) with a big RAID drive. The server will be used by many users for their backup. How can we set quota so that every Time Machine backup takes up a limited amount of disk space?

We tried setting quota on the server with edquota but Time Machine on the client still displays all free space on the volume as "free" regardless of quota. Backup just fails on the client with a small message in the log file when quota is reached.

We also tried to set a fixed maximum size on the sparse disk image that TimeMachine uses but it gets reset to infinite size on every backup.

We don't want to partition and share the disk with one partition per user as that would mean hundreds of partitions (how many does OS X support? :-)

Any ideas?

share|improve this question
    
By now we have changed to using Linux with netatalk 2.2 (netatalk.sf.net) on the server. netatalk 2.2 has a volsizelimit option specifically for fooling Time Machine. –  robcast Apr 16 '12 at 17:49
add comment

1 Answer

Looks like you're trying all the right things. I do this with a Drobo for a small number of Macs now. I have a 2TB volume, but I don't want that to fill up with old TM backups so I just use the sparseimage trick and it works great.

It is unclear why this is getting reset for you. Perhaps you should try this again.

I found these instructions useful: http://www.somelifeblog.com/2009/02/fixed-time-machine-backup-to-network.html

share|improve this answer
1  
Thanks for the heads up. I'll try again with the instructions you mentioned and report back. –  robcast Sep 13 '10 at 9:20
    
It seems Apple changed the behavior in 10.6.3: it always resizes the sparseimage but you can try to interfere by locking the Info-files (hintsforums.macworld.com/archive/index.php/t-110709.html) –  robcast Apr 16 '12 at 17:45
    
I'm using 10.7.3 and I don't see that behaviour. However, I also didn't see this behaviour under Snow Leopard (10.6). –  mkoistinen Apr 16 '12 at 20:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.