Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have WD external hard disk, which was working fine. Its MS-DOS formatted. I have downloaded a file in .mkv, which works fine, and isn't corrupted. Upon copying the 8 gb file, it says "The file is too big to be copied", whereas its only 8 GB being copied on 500GB disk. I tried formatting it. still nothing. What else can i do?

share|improve this question
    
Your error is slightly different than the error here. Glad this was sorted rapidly. –  bmike Mar 13 at 12:42

1 Answer 1

up vote 10 down vote accepted

The HDD is formatted using FAT32 which has a known limitation of 4GB file size. You need to format it using exFAT which is supported by OS X and Windows.

share|improve this answer
    
it worked.thanks –  Nofel Mar 9 at 7:37
    
You're welcome. –  Melwan Mar 9 at 9:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.