Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

As the title suggests, My Mac will not receive an address via DHCP from a certain network. No matter if it's connected via WiFi or ethernet, it always fails. Even when I boot into Windows 7 there's no luck (so it's not the OS). All the other computers, older MacBooks, and iPod/Phones work great on the network. Take it to a different network and it works flawlessly.

Has anyone else had this problem? Did you find a way to fix it?

Update: Manually entering a valid IP (copied from another computer that's on the network) gets me a connection. The issue seems to be just in the DHCP.

share|improve this question
    
Do you get a 169.254 address or nothing at all? –  hobs Apr 18 '11 at 21:22
    
A 169.254... address –  cpf Apr 18 '11 at 21:39
    
Are you selecting DHCP with manual address or static IP? –  hobs Apr 18 '11 at 23:52
    
Setting it to "full" DHCP produces the self-assigned addresses. Static IP worked fine (with up-to-date details). I just cleared the NVRAM and we'll see tomorrow if that did anything at all. –  cpf Apr 19 '11 at 1:43
    
Turn airport off. Open up console and select "all messages" on the left-hand side. Turn Airport back on. Wait for the airport messages to show up. Paste them here so we can have a look. :-) –  Harv Apr 22 '11 at 0:53
show 1 more comment

3 Answers

Two shots in the dark here: does the network in question require a DHCP Client ID to be set in Network Preferences? (System Preferences > Network > Advanced > TCP/IP)? Some networks do require that.

Second, is the router set to block the MBP's MAC address? That would account for the failure to connect via OS X or Win7. Hard to believe that could be the case, but I suppose it's possible.

share|improve this answer
    
Neither. I can access it fine on my iPod without doing anything more than selecting it from the network list (after pressing "Forget this network" of course). I can also manually enter a valid IP on my MBP and be connected quite fine; the issue seems to only be the DHCP. –  cpf Apr 18 '11 at 21:39
    
@Negrino you just saved my day ;) –  muffel Nov 11 '13 at 11:23
add comment

Have you tried to set 'Configure IPv6' to OFF in the Network > Advanced settings for the en0 ?

I've just had a sim problem as yours (never got an address, other windows machines worked) that was resolved by turning it off. Then my IPv4 address was received.

share|improve this answer
    
Had the exact same issue. Turned off the IPv6 (binary10 answer) and it worked straight away. Thank you –  user46706 Apr 4 '13 at 13:46
add comment
up vote 0 down vote accepted

My issue was fixed by clearing the NVRAM (hold Option+Command+P+R at bootup till it chimes twice, to save you googling), but I never did try the IPV6 thing so it might work too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.