Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently did a complete wipe of my late 2009 MBP and restore using a Time Machine backup, so I would have uninterupted space at the end of the drive for creating a Boot Camp partition. The Boot Camp tool runs fine now, so I insert my Windows 7 DVD when it tells me to, reboot the computer, it appears to start running off the DVD… but then I just see a black, blank screen. I left it in that condition for over half an hour with no changes. There shouldn't be anything else weird with my system.

Has anyone else experienced this? Apple's website has a downloadable fix for an iMac attempting to install Windows 7, with the same symptoms. I tried that fix even though I have a different Mac, but it didn't work either. Help?

share|improve this question
    
32 bit or 64 bit windows 7? –  hobs Apr 20 '11 at 12:02
    
I have exactly the same issue with exactly the same symptoms. Resetting the SMC & PRAM made no difference. What is interesting is than an XP CD boots into setup just fine, it's only Windows 7 boot DVDs, one of which I used a year ago to install windows 7 on the same machine with no issues whatsoever that fails. –  user6119 Apr 29 '11 at 6:40
    
I have the same machine (MacPro5,2) and am also having the same problem - now have spent a whole day messing with this. Its definitely something to do with the graphics adapter. –  ferdil Apr 25 '12 at 13:55
add comment

1 Answer

Yep, this is something that can happen, and there are two Apple articles to address it.

Boot Camp: iMac displays a black screen during installation of Windows 7 http://support.apple.com/kb/TS3173

  • Download the autounattend.xml and updated graphics drivers

Boot Camp: Start up to black screen after installing Windows
http://support.apple.com/kb/TS2600

  • Reset PRAM
  • Reset SMC

You mentioned that you did already download a fix from Apple, so I am assuming you may have followed the first article already, and if that is the case there are some instructions floating around the net to try to resolve the graphics issues by removing an ATI driver pre-reboot.

  • Run the Boot Camp Assistant in OS X as normal and create a partition when asked, then insert your Windows 7 disc to reboot and begin the process proper.
  • Windows 7 requires the NTFS file system, so once in the installer just select your new partition (labelled BOOTCAMP), click on Drive options (Advanced) and choose to format it. Then select the newly formatted partition and continue.
  • Windows 7 will begin installing, and once it gets almost to the bottom of its checklist, it’ll try to reboot. Now, if you leave it here, you’ll get so far and see the black screen. Any further attempts to reboot will bring you to the same dead end.
  • Instead, restart and press a key to boot from the Windows 7 disc when prompted. Rather than running the installation again, choose the little option at the bottom to Repair your computer. Decline any suggestions that pop up until you see a list of options with Command Prompt at the bottom. Choose that option.
  • At the Command Prompt, type DEL C:\WINDOWS\SYSTEM32\DRIVERS\ATIKMDAG.SYS to delete the default ATI driver, then close the window and reboot.
  • This time, Windows should successfully initialise a more appropriate display driver, allowing you into the desktop. From here insert your OS X disc to install the relevant hardware drivers as you normally would, then run Windows update to clear up any leftovers.
share|improve this answer
    
I read both of those articles already. The first one did nothing (but I don't believe it would apply to my machine anyhow). The second one assumes you've already installed windows. –  Judy Apr 20 '11 at 5:24
    
While the second one does assume you installed windows, reset the smc and pram anyway, I have read reports of this fixing it, as the pram holds the last booted disc in memory if I remember correctly. I have also seen reports of connecting a secondary monitor helping the issue. –  hobs Apr 20 '11 at 12:07
    
I'll try resetting the smc and pram tonight, and I'll let you know if that works. –  Judy Apr 20 '11 at 19:05
    
Sweet! Any joy on that alternate monitor? –  hobs Apr 20 '11 at 20:53
add comment

protected by Community Jun 12 '11 at 14:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.