Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently bought am older Mac (Mac G5 with Mac OS X 10.4 Tiger). I have a PC keyboard and when I tried the keyboard shortcuts for text editing such as copy, paste, cut, select-all I realized they don't work.

I researched the web for some help and found that the Mac keys are not in the same place as Windows keys. Most probable alt acts as control because that's where the command key on a Mac keyboard is placed or sometimes Windows key. None of the combinations seem to work.

The control key works on the Mac because I can switch between FireFox tabs by pressing control + tab, control + shift + tab or I can use control + Z and control + Y.

Do you have any ideas why this is not working and how I can fix it?

share|improve this question
    
I managed to solve the issue. I downloaded DoubleCommand and selected Control key acts as Command Key and hit Activate. Works perfectly now. –  razvan Apr 17 '11 at 10:59
add comment

migrated from stackoverflow.com Apr 17 '11 at 9:31

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 3 down vote accepted

Almost all of the keyboard shortcuts you've learned on Windows are the same on the Mac. The difference is which modifier key you use to invoke them.

On Windows, shortcuts are typically invoked with the Ctrl modifier key.

On the Mac, you use the Command key, also known as the "command" key. It's in the same physical position as the Alt key on a Windows keyboard, but is nothing like the Alt key.

The Mac has its own Alt key, labeled Opt/Alt. Its primary use is a secondary modifier for keystrokes. Command-Option-S might be "Save As", for example, while Command-S is regular "Save".

The Ctrl key is there on a Mac keyboard, too, but it's hardly ever used for anything.


The relative layouts look something like this:

     PC:     Ctrl Windows Alt

     Mac:   Ctrl Opt/Alt Command


The problem is that you're most likely using a PC keyboard on your Mac. In that specific case, the Opt/Alt and Command keys are reversed. You can change this in System Preferences, under Keyboard. Truly a huge pain in the rear for switchers. That layout looks like this, instead:

     PC keyboard on Mac:   Ctrl Command Opt/Alt


Apple's website has some pretty good hints and tips for Windows switchers. Start here for answers to your specific question about keyboard shortcuts. Then go here and read everything!

share|improve this answer
    
Thanks for the information, now I know why the command key is next to the CTRL key , its because of the windows keyboard. Still didn't help me to much because command key(windows on my keyboard) didn't work with those key combination's. Seems I had to download DoubleCommand and switch command key with CTRL and works great now. –  razvan Apr 17 '11 at 11:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.