Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a retina MacBook Pro 15" running Mac OS X 10.9.4. When I wake it from sleep at work, it's connected to the wifi network before I've even entered my password. But at home, with a Airport Extreme base station from about 2009, it takes 30 seconds at minimum every time I wake from sleep, and sometimes up to a couple minutes.

I've tried rebooting the Airport Extreme, it doesn't need any firmware updates, and of course the laptop itself has been rebooted many times since this problem all started (months ago). I'm sitting in the same room with the thing, so the signal power should be great - not to mention my iOS devices (and other Macs) have no problems connecting instantly to the Airport. So it seems like it's got to be a local computer problem, but then why do I have no problem instantly connecting to other wifi networks?

share|improve this question
1  
Did you remove the network from your list of known networks and connected again? –  Rob Feb 23 at 14:14
    
I've tried removing all known networks except for my home and work, and putting home up top, but no improvement. –  Charles Mar 12 at 10:53

5 Answers 5

In my professional experience, if you travel a fair amount and use hotel & other free wifi nets, the list of preferred networks can grow unwieldy, and your home network may be way down on the list. @Robuust's suggestion should be amplified to include deleting all preferred networks in that list you may never use again, in addition to any regularly-used networks with connection problems.

In addition, I suggest that once you have re-established connection with your home wifi, that you drag it to the top of the list with this option:

enter image description here

Naturally, if it is your only network, this step is superfluous.

Additional information edit:

You might also want to try deleting the associated login key to this network in Keychain Access.

share|improve this answer
2  
I tried deleting the network and its associated login key, along with all the other networks except for my work one. There hasn't been any improvement. –  Charles Mar 12 at 10:53
    
That's disappointing. 10.9.2 has been released. Perhaps the update will fix something? –  IconDaemon Mar 12 at 12:20
    
This post does not cite any references or sources. Please help improve this post by adding citations to reliable sources. Unsourced material may be challenged and removed. –  Buscar웃 Jul 9 at 15:49
    
No problem, just state then "my Professional experience" as source. –  Buscar웃 Jul 11 at 8:22

OS X 10.9.4 fixes a long-standing bug in Mavericks related to wi-fi connections coming out of sleep. http://support.apple.com/kb/HT6281?viewlocale=en_US&locale=en_US

share|improve this answer
    
I upgraded to 10.9.4 as soon as it came out but it hasn't solved my wifi issue. I still wait 30+ seconds every time I open up my laptop on my home wifi. –  Charles Jul 9 at 14:09

Try setting a manual DHCP (static IP) address:

  1. Go to System Preferences → Network → Wi-Fi → Advanced → TCP/IP.

  2. Set Configure IPv4 to Using DHCP with manual address.

  3. Enter your IP address, click OK and Apply the changes.

  4. Disconnect from your network.

    sudo /System/Library/PrivateFrameworks/Apple80211.framework/V*/A/R*/airport -z
    
  5. Reconnect to the network using the menu bar item.

share|improve this answer
3  
It's DHCP, not DCHP (I cannot edit it because edits should be at least 6 characters.) –  reg Mar 1 at 18:00

Go to System Preferences -> Energy Saver and uncheck the 'Wake for Wi-Fi network access' option

This fixed the network-not-connecting-after-sleep issue on my brand new MBP 10.9.4, but I wasn't using an Airport Extreme... so maybe that part of the equation is just coincidence in your case.

share|improve this answer

If you don't mind losing all your network settings, you can try a total reset of your network preferences as described here.

  1. Close System Preferences
  2. In Finder, go to folder /Library/Preferences/SystemConfiguration
  3. Delete all network related files, namely:

    com.apple.airport.preferences.plist
    com.apple.network.identification.plist
    com.apple.smb.server.plist
    NetworkInterfaces.plist
    preferences.plist
    
  4. Reboot
  5. Go to System Preferences and reconfigure your network settings.

I've found this procedure useful for cleaning the mess in network profiles which was left by many subsequent system upgrades.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.