Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

This issue has been going on and off for years. I still don't consistently get the new mail sound when new mail arrives.

Sometimes it happens, most of the time, never.

10.6.7

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Since you mention this has been going on for years, this is likely related to a longstanding bug in Mail.app and fetching mail with IMAP. Try the instructions here and see if it helps:

In Mail, open Preferences and go to Accounts » Advanced in all your mail accounts and turn off the Use IDLE command feature. Next, go to the General section of Preferences, and set Check for New Mail to Every minute -- you can set a longer interval if you want, so long as you don't set it to Manual.

Now your mail alerts should play for every incoming message, but you will see your messages up to one minute later than you would with the IDLE mechanism.

share|improve this answer
    
it's a shame apple doesn't recognize this issue. but thanks for the help, it works. –  user5686 Apr 17 '11 at 14:59
    
You can always file a bug report: apple.com/feedback/macosx.html –  michaelmichael Apr 17 '11 at 18:36

I changed back and forth from classic view and the sound reappeared. Open Mail, select preferences, select view (check or uncheck to make it the opposite of what you have there). Close Mail...open and the sound returns.

You can then switch it back to the view you liked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.