Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On my old MacBook Pro, I mostly used the US-International keyboard, which used the Opt key to switch to a large set of markings. On my new MacBook Pro with OS X 10.9 (Mavericks), I can't find it. The only "English" keyboard has just a few such "dead keys", but none of the marks used by eastern-European languages are present. I've found a number of references to US-International keyboards on Mavericks in various forums, but no clues for how to enable it. Does anyone here know?

share|improve this question
    
The keyboard you refer to has been called "US Extended" in all Mac OS versions from 10.3 to 10.9. Before that it was called Extended Roman. "US International" is quite different, intended to emulate a common Windows layout, and is only good for W. European languages. It was added by Apple starting with OS 10.6, though there were 3rd party versions you could add yourself available earlier. –  Tom Gewecke Feb 16 at 17:42
add comment

3 Answers

I think the keyboard layout you are looking for is "US Extended".

Here is how to enable either "US Extended" or "US International-PC".

enter image description here

In the Keyboard preference pane, click on the "plus" button in the lower left to add a new keyboard layout. Then select "English" in the next dialog box, scroll down to the bottom, select "U.S. Extended" or whatever else you choose, and click "Add".

enter image description here

Here are the diacritical "dead keys" available in the standard US layout.

enter image description here

And here are the many more diacritical "dead keys" available in the US Extended layout, which provide for Eastern European and Slavic languages that use the Latin alphabet, along with other languages as well.

enter image description here

This screen shot shows the "option" keys in US Extended.

enter image description here

This screen shot shows the "shift-option" keys in US Extended.

Update

Here are other settings you need to be aware of.

enter image description here

Enable the pull-down menu on the menu bar. I would also un-check the box for "Automatically switch to a document's input source" because I find it too confusing in practice. But at least now you know where that setting is located.

enter image description here

It is also helpful to go to this pane and click the box to enable the Keyboard Viewer, so that you can see an on-screen floating window that shows you all the available diacritical dead keys in the layout that you have selected.

enter image description here

This is what the menu looks like (with whatever multiple layouts you wish to choose)

enter image description here

Here is where you can enable or disable the custom keyboard shortcuts to rotate among the list of different keyboard layouts which you have selected. I decided to disable these keyboard shortcuts because I found that it was too easy to accidentally rotate among multiple keyboard layouts and I was confusing myself as to which layout I was using at any given time. I would rather use the pull-down menu on the menu bar. It takes more time, but at least I am 100% sure of which keyboard layout I am using at any given moment.

share|improve this answer
add comment

I seem to have partially "solved" the problem, though I don't quite understand how I did even that. When I tried to follow the above instruction, I did find the "US Extended" keyboard setting, but when I selected it, I saw the same 5 dead keys as in the "U.S." keyboard, but none of the others shown above. I poked around at it for a while, tried varying various settings, with nothing changing, until I suddenly noticed that the "US International - PC" keyboard had appeared in the list.

So I tried it. Nope; it also showed the same 5 dead keys, good for French and German (which I use a lot), but not so good for Danish or Czech or Croatian. then, after wondering where it was all hiding, I decided to take time out and examine a bunch of other language-specific keyboards. I added languages like Czech, Polish, Croatian, etc. to my list, which already had Russian, Bulgarian, Greek, Hebrew, etc., but no other Latin-based keyboards. I had them listed on my old machine, but found I never used them, because it was easier to use the US-International keyboard for all of them.

After a while, I went back to the original problem, looked at the "US Extended" keyboard -- and it had changed to show all the dead keys I'd had on my old machine. My first reaction, of course, was "WTF?", and then conjectured that turning on those other language-specific keyboards had somehow also changed the "US Extended" keyboard in this way. In fact, this is implicit in the 2nd answer above, though it doesn't explicitly state that the other language keyboards are required for the "US Extended" keyboard to support those other language; it merely suggests selecting a few of them.

But this doesn't really make sense. As I understand it (and learned on my old machine), what used to be "US International" and now seems to be "US Extended" is designed to allow the use of a single keyboard that supports many Latin-based languages, rather than switching keyboards for each of them. You'd want to use one method or the other, but probably not both. So why would anyone make the choice you want to use available only if you first choose the one that you don't want to use?

But of course I'm not privy to the internal decision-making process at Apple, so I'll probably never understand it.

I still have to find a solution to a follow-on problem: For several hours this afternoon, while working in French, I found that opt-6 produced a circumflex as the Keyboard viewer says, but only for i, o and u. When I tried to use it to get a circumflex over an a or e, it ignored the opt-6 and the following letter, plus several more character, and then returned to normal as if I hadn't typed any of those keys. About an hour ago, this problem went away, for no reason that I can guess, and â and ê now seem to work fine. But since I don't know what caused and then corrected this, it'll probably happen again.

Anyway, I should give a tentative thanks for the encouragement via examples of how it's supposed to work. But the idea that it's all dependent on first selecting a few other languages' keyboards, which you will then ignore after "US Extended" finally works as described, is a bit troubling. I hope I'm interpreting it wrong, and it's not actual that weird. But I never saw the large set of dead keys until after I did that, so it looks like some sort of enabling trigger was pulled that changed the "US Extended" keyboard.

It might help if there were an easy way of finding an explanation of it. Do all customers who use eastern European languages find it this difficult to get it working right? Or do they all use their "native" keyboard? I know a lot of people who use those languages here in the US; maybe I should ask some of them what they know about it.

share|improve this answer
    
US and US International are perfectly fine for Danish, Swedish and Norwegian. Certain extra characters are on the option keys and do not require dead keys. –  Tom Gewecke Feb 14 at 23:35
    
Regarding your circumflex problem, what app did this occur in? –  Tom Gewecke Feb 14 at 23:37
1  
It sounds to me like you may be switching keyboard layouts without knowing it. Make sure you have the Input ("flag") Menu showing in the Menu Bar at the top right of the screen. To use US Extended, make sure you see the US flag with the U underneath. US International, which can only do a few accented characters, has the flag with the PC underneath. –  Tom Gewecke Feb 16 at 23:34
    
You must be switching keyboard layouts without knowing about it. There are shortcut keys you can disable or enable for switching layouts. Also, have you enabled the pull-down menu on the menu bar so you can select between layouts with the mouse? I think that there's also a pesky setting somewhere that changes layouts depending on what document you are editing. You need to find out how to turn that off, because it will fool you when you least expect it. –  Wheat Williams Feb 17 at 22:50
    
I will add additional screen shots and instructions to my answer. –  Wheat Williams Feb 17 at 22:55
add comment

As an alternative to US Extended, you could consider the Character Picker, a popup menu which will appear when you hold down the key for a base letter in OS 10.7 and higher. I think the options it offers may cover the languages you need.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.