Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Is there a way to tell Finder to not peek inside or generate thumbnails for files based on a particular network share or folder?

I've got a tape archival system which presents an SMB (Windows) network share to clients. Clients can see all the files and folders that have been put on the network share, and the data gets transparently archived to tape in the background leaving a small 'stub' file on disk. When a read request on a file is issued by a client, the tape system recalls the file from tape and sends it back to the client. The upshot is I get a large amount of cheap high-latency storage, but with a very simple network share interface.

However, there's a significant problem with Mac clients: when Finder sees a directory full of files, it attempts to generate thumbnails and read other data about the file. Finder assumes that it can get data relatively quickly, so when it sees a directory full of 100GB worth of mov files, it requests to read each one so that it can generate the thumbnails.

Predictably, this sends the tape drive crazy, as it tries to pull down each of these files from tape just to generate the thumbnails.

Ideally, I'd like to tell Finder to not read any data inside the file until it's explicitly asked for by the user, ie. they request to copy it to their local disk. Is this possible?

share|improve this question
    
This issue with thumbnails over the network is one of the main reasons I use PathFinder –  Mark Apr 14 '11 at 12:42
    
I'll second @Mark 's suggestion to evaluate Pathfinder to mostly replace Finder in this situation. –  bmike Apr 14 '11 at 22:22

4 Answers 4

I don't know if this will work in your particular case, but you might as well try it. Open the Samba share and press Command+J, then uncheck "Show icon preview" and click on "Use as defaults". This way the Finder won't try to extract info from the file to generate a thumbnail, no matter if it is an image, or a mp3, or a movie. However this would be valid only for the root directory you just changed the settings to, so the local hard drive stuff should be ok.

share|improve this answer

By pressing cmd+J then unchecking "Show icon preview", I've solved the flooding errors in my log that was :

com.apple.quicklook.satellite[16222]: Failed to initializeServer(), returned 5 
com.apple.quicklook.satellite[16222]: Failed to communicate with qtkitserver: Connection invalid

if that can help too. I didn't understand that the setting is not the same for the Desktop, windows in column view… so I've been looking for a system-wide solution that actually was a checkbox. Then using TotalFinder and always in column view, you only have to check twice to apply this setting "everywhere", that's it.

share|improve this answer

First of all, I am using http://cantuse.it/2008/11/disable-video-thumbnails-in-mac-os/ as a reference.

Now originally I remember removing and modifying the quicklook generators to associate a blank filetype with the text generators, in this case, it looks like the video thunbnail generation is handled by the same process.

Move /System/Library/Frameworks/QuickLook.framework/Resources/Generators/Movie.qlgenerator somewhere else, and it should not try to generate the thumbnails in the future. Good luck!

share|improve this answer

You can disable the QuickLook process responsible for generating the thumbnails.

On Mac OS X 10.6, use the following command to disable the automatic launching of the quicklookd daemon process:

sudo launchctl unload /System/Library/LaunchAgents/com.apple.quicklook.plist

Mac OS X may assume this process is always available, so always back up first and tread with care when disabling system wide services and daemons.

share|improve this answer
    
It did occur to me to disable the process altogether, but having spoken with the team they would find the disabling of thumbnails system-wide unacceptable. Hence looking for a network share / directory-only solution. –  growse Apr 15 '11 at 8:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.