Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Due to an accident, my entire applications folder with all the support files, including plists and caches got deleted.

I tried restoring by files from the most recent Time Machine backups but I cannot retrieve my applications with the support files.

I even tried it with migration assistant on a new image.

Is this impossible?

Must I start from scratch?


Details of the ‘accident’

I was using this app called ‘AppCleaner’ that also automatically deletes related support files which are normally left behind if one simply trashes an Application.

In the search view, I typed the app name and I selected all the apps in the results using Command + A. Unfortunately, this selected every single Application in the Applications Folder in the background and I trashed and deleted all files.

Anyway.

I tried to restore the applications and library from my Time Machine Back-ups but failed to do so because I didn’t have enough space to restore. (I have a 11inch Macbook Air 2012 64GB SSD

When I tried to restart in recovery mode, I had the same problem, I was disallowed the option to restore using my time capsule backups because my SSD didn’t have enough space for the backup.

I then tried to restore it to a totally different but new image on a 64GB USB3.0 Sandisk USB Stick, but the process stopped after hours of being stuck around 30.4 percent and the computer was unable to boot, leaving me with a persistent verbose message suggesting it couldn’t identify the os, kernel or anything.

I finally tried restoring the state using migration assistant on the very same SSD that had my files missing. This happened successfully and I have all my applications in the applications folder.

But now I have 13GB free (I had 2GB before) and all my application support files, saved states, preferences, caches and customizations are gone.

Basically, it feels like I just got a new macbook with my documents and itunes folder loaded on to it.

How can I get my apps back to the pre-deletion state or is this impossible? Do I have to start from scratch? I thought my Time Machine Backups would restore it to exactly the same state, am I wrong?

--

Screenshots:Screenshots

share|improve this question
    
Thanks for responding @grgarside I'm sorry I didn't do a good job explaining as I made this post in haste. I'll clarify. All my applications work exactly like they would if they were freshly installed and had zero user data or customization. Example, -I have zero workflows in Alfred -I'm signed out of iCloud in Mail App -My growl notifications are reset Basically, everything that's supposed to have caches, plists, saved states etc. have nothing. zero, zilch. – Expiration Supreme Feb 4 '14 at 16:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.