Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My MacBook Pro Retina is currently reporting 100% battery in the menu bar, however if I run the following command in terminal;

ioreg -l -w0 |grep Capacity

The following is returned;

| |           "MaxCapacity" = 8520
| |           "CurrentCapacity" = 8434
| |           "LegacyBatteryInfo" = {"Amperage"=679,"Flags"=7,"Capacity"=8520,"Current"=8434,"Voltage"=12906,"Cycle Count"=28}
| |           "DesignCapacity" = 8440

If we do (8434 / 8520) * 100 we get 98.990...% (CurrentCapacity divided by MaxCapacity and multiplied by 100)

I ran the command earlier today and there was an even greater difference between what terminal reported and what the menu bar icon reported (about 5% different).

What causes this? Thanks

EDIT: My MacBook has been plugged into power and saying 100% battery in the menu bar for over an hour, but terminal has been saying 98.990...%. However, I ran the command again and it now says 100% in terminal;

| |           "MaxCapacity" = 8520
| |           "CurrentCapacity" = 8520
| |           "LegacyBatteryInfo" = {"Amperage"=0,"Flags"=5,"Capacity"=8520,"Current"=8520,"Voltage"=12862,"Cycle Count"=28}
| |           "DesignCapacity" = 8440

(CurrentCapacity and MaxCapacity are now equal)

Does this mean my MacBook 'lies' and says the battery is charged an hour before it actually is?

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.