Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have just moved onto OS X from Windows and am using an early mac pro.

Inside eclipse, when I hover over the toolbar, there are various keyboard shortcuts, (like F11 for 'Run').

However, when I press F11 on my keyboard, all it does is making the volume on OS X go down. Am I doing something wrong? This keyboard shortcut is pretty useful so Id rather not lose it.

share|improve this question
1  
Try holding the Fn key before the Function buttons. –  user479 Apr 6 '11 at 21:50
    
Nope, didnt work. –  maxp Apr 6 '11 at 22:13
    
Similar question on StackOverflow: stackoverflow.com/questions/602040/… –  nuc Apr 6 '11 at 22:17
    
may be you can re-map the volume key shortcuts. Change it to fn + f11 and then try.. –  garikapati Apr 6 '11 at 23:08
add comment

1 Answer

up vote 2 down vote accepted

Go to System Preferences -> Keyboard and check "Use all F1, F2, etc. keys as standard function keys." System Preferences can be found in the Apple menu, or in your Applications folder. Then, make sure that Eclipse still has the F11 shortcut for 'Run' - it might be different on OS X.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.