Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

This is my current set-up:

Wireless network, multiple macs connected, two of them are standing next to each other. As I want fast file transfer between those, I've got an ethernet cable between them. With IPv4 turned off (on ethernet) on both of them, and Ethernet on one in the service order, this all works. Kind of.

Because the Mac will decide whether it wants to use wireless or wired, it seems like it will only use the ethernet when it transfers bigger files. Is there a way to always let them use wired instead of wireless?

share|improve this question
1  
Shut off airport? :) –  Jason Salaz Apr 6 '11 at 14:24
    
I missed the IPv4 turned off in my earlier answer. Would you perhaps share a routing table or let us know if you want to route IPv6 or something lower like link level? –  bmike Jul 9 '11 at 19:59
add comment

4 Answers 4

When there are 2 routes available, I usually just temporarily Turn Airport Off in Network Preferences when I want to force a transfer (or other network connection) to start over the wired ethernet port.

share|improve this answer
add comment

The following should work for you and enable you to choose when to use the direct Ethernet link. Try this:

1) Manually assign IPs to the Ethernet interfaces of the two connected Macs. Use IPs that are in a different subnet than the subnet being used on your wireless network. FOr example if your Airport network is using 192.168.X.X then use 10.0.0.1 and 10.0.0.2 for the wired Ethernet interfaces with a 255.255.255.0 mask.

2) On both Macs order the Ethernet interfaces after the Airport interfaces in Network preferences pane.

3) On the computer assigned the 10.0.0.1 IP, use a text editor to edit the "/etc/hosts" file and add an entry like "10.0.0.2 Mac2Ethernet". Choose any hostname you want in the place of Mac2Ethernet.

4) On the computer assigned the 10.0.0.2 IP, use a text editor to edit the "/etc/hosts" file and add an entry like "10.0.0.1 Mac1Ethernet". Choose any hostname you want in the place of Mac1Ethernet.

5) Then, test things out by opening terminal on one Mac and trying a "traceroute Mac#Ethernet". It should only have one hop, directly to the other named Mac". Try it in reverse from the other mac as well. You may also want to test a traceroute to an Internet destination and make sure that it does NOT route through the other Mac but uses the Airport network instead.

6) Then, when you want to transfer a file from one Mac to the other simply use the alternate hostname Mac1Ethernet or Mac2Ethernet for those Macs and the traffic will only use the direct connected Ethernet interfaces. For example, on Mac1Ethernet, type command-K in Finder to get to "Connect to Server" dialog, then use afp://Mac2Ethernet to connect to the other Mac.

I'll leave the testing of this specific configuration to you but can tell you that I do currently use something very similar to connect my iMac to a TimeCapsule next to it using directly connected Ethernet. This allows very fast wired backups for the iMac even though it uses a different Airport network for all other home networking and Internet.

share|improve this answer
add comment

Turn off the Airport on one of the Macs. On the other, enable Internet Sharing, sharing your Airport connection by ethernet. This will make all network traffic from the airport-disabled computer go through the other, which will slow things down, but it might be worth it in your case.

share|improve this answer
    
The "correct" (read: most UNIX-y) and most efficient way of fixing this, would be to edit your routing tables or something, but this is certainly the Mac-est way of doing it - a couple clicks, no command line. –  spwert Apr 6 '11 at 17:40
    
And here's how you'd do that: chimac.net/2010/04/27/… –  spwert Apr 7 '11 at 1:46
    
But then my internet speed half as fast :/ –  JCBK Apr 8 '11 at 13:27
    
Only if both computers are constantly trying to use the Airport's whole bandwidth. And if that is a problem, follow the instructions in that link to set up the static route instead. –  spwert Apr 8 '11 at 18:04
add comment

Go to your network settings and drag Ethernet to the top of the list (the pane must be unlocked and the interface connected for you to be able to change the order).

share|improve this answer
    
If that works, then the default route will no longer get packets to the internet. Macs already prefer ethernet over WiFi by default, so for the internet to work, the mac has a second check to determine a non-preferred network has better connectivity and it shifts the default route to the less-preferred connection. –  bmike Jul 9 '11 at 18:31
    
Did you even notice that he disabled IPv4 on Ethernet? There's no route over ethernet. I hate to be the one to break it to you, but you don't seem to understand this as well as you think you do. –  bahamat Jul 9 '11 at 18:48
    
I didn't notice - thanks so much for catching it! I'll remove my answer above since without the OP's routing table, we're shooting in the dark. Don't worry about breaking news - especially when I'm clearly barking up the wrong tree like this time :-) –  bmike Jul 9 '11 at 20:01
    
I'm glad this didn't turn heated :-). Thanks for being a open about it. If you were the person who voted down, could you kindly reverse it? –  bahamat Jul 9 '11 at 22:04
    
If you edit the answer - i could try to vote again - it's locked to me at this point. It's not clear the order will make any difference when IPv4 is disabled (I'm not even sure how one would do that trickery since when I set IPv4 off on Snow Leopard - even IPv6 that used to work fails and it won't use that interface.) But I'll upvote your answer just for thanks for catching my error. :-) –  bmike Jul 11 '11 at 4:27
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.