Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Have bought Mac air 11 inch today. Cannot make @ key function. I Have pressed alt and the @ key together. Nothing happens. It seems that other signs on the right side are not the same as what I see on the screen. For example, if I press ?, it gives me -. Is something wrong/broken?

share|improve this question
    
Sounds like you have perhaps got the Italian keyboard layout active instead of US. –  TomG Dec 22 '13 at 23:39

2 Answers 2

It seems like a localization problem, your keyboard seems to be configured to a profile different the one represented on its key's markings.

  • Open System Preferences:

enter image description here

  • Go to Keyboard:

enter image description here

  • Go to Input Sources:

enter image description here

  • On the bottom left, click the + and add whichever keyboard is appropriate to your MacBook. Typically, it's U.S. English:

enter image description here

  • Lastly, select all the input sources on the left that you don't use (probably every except the one you just added) and click the minus button to deactivate them (to prevent them from accidentally becoming active).
share|improve this answer

Maybe your keyboard does not match the settings in your System Preferences. It would be good to include the layout of your keyboard i.e. English UK, English US, or maybe another language's default.

To check your System Preferences setup go: System Preferences --> Keyboard --> Input Sources. There you will find which button layout is set.

By matching that to your actual keyboard layout you may be successful resolving your issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.