Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On prior versions of OS X, it was possible to display hidden files in a Finder dialog box (Open, Save, etc.) using Command-Shift-Period.

In Mavericks, that feature isn't working for me. Is there another command that one can use? I would prefer not to globally enable hidden files.

EDIT: I'm the one offering the bounty. It seems I cannot comment because I don't have enough rep now :)

So... yes, I'm also running 10.9.1 and it does not work. I have used it in previous versions of OSX and it worked fine. The script mentioned is OK to show the hidden files in Finder, but it does not work that well when using the open/save dialog.

My use case: sometimes I need to open/save files to the /tmp directory. In previous versions of OSX I just used the dialog to get to the disk root, and then press CommandShift. and then I was able to see the /tmp directory (actually /private/tmp).

So, if you guys are using the same version of OSX and it does work for you, I guess there must be a way to re-activate this. Any ideas?

share|improve this question
4  
I just tried Cmd-Shift-. in an Open... dialog (in Chrome on 10.9.1) and it worked great. Are you: 1) sure that the folder you're using the short cut in actually has hidden files in it (I used it in ~)?; 2) That Cmd-Shift-. hasn't been remapped to something else on your system? –  Ian C. Dec 24 '13 at 23:38
2  
This still works on my 10.9.1 –  markhunte Dec 25 '13 at 0:11
    
@Cristian: My machine is currently not experiencing the issue you are having, so it's hard to replicate/resolve the issue for me; however, hopefully I can help you isolate what may be causing it. Is the user account you are using on your machine set up as an Admin account? Also, when was the last time you performed a Repair Permissions on the computer? –  Sly Raskal Dec 31 '13 at 6:27
    
@Cristian and Boyd, I just wanted to clarify something. Does this issue occur in any open/save dialog box, basically is it application independent, or does it occur in only a finite number of applications. –  Sly Raskal Jan 1 at 19:55
    
i confirm that the old toggle shortcut stopped working for me too on 10.9.1. had to resort to globally showing all files always with defaults write -g AppleShowAllFiles -bool true –  Viktor Trón Jan 14 at 4:23

7 Answers 7

I'm currently running OS X (10.9.1) and just tried the + + . keyboard shortcut in a save dialog box and it worked just fine.

I've also setup an AppleScript on my machine with a keyboard shortcut of ^ + + + . which toggles the visibility of hidden files within Finder whenever I want. This way I don't have to manually run a terminal command to show hidden files, and I can quickly turn it off to avoid accidentally modifying system files. I use FastScripts (also available in the Mac App Store) to allow me to set the keyboard shortcut for my AppleScript, and placed the AppleScript in my ~/Library/Scripts Folder.

Here is the AppleScript in case you wish to give it a try:

tell application "System Events"

    set hiddenFilesDisplayStatus to do shell script "defaults read com.apple.finder AppleShowAllFiles"
    set hiddenFilesNewDisplayStatus to "NO"

    if hiddenFilesDisplayStatus is "NO" then
        set hiddenFilesNewDisplayStatus to "YES"
    end if

    do shell script "defaults write com.apple.finder AppleShowAllFiles " & hiddenFilesNewDisplayStatus
    do shell script "killall Finder"

end tell
share|improve this answer
    
Thanks. Give the keyboard shortcut a try. I've been using it for a number of years and has come in handy numerous times. –  Sly Raskal Dec 26 '13 at 3:25
3  
Tried in 10.9.1. Seems to work but need to click out and into folder for it to update. Not very elegant, but effective. Thanks –  Joop Dec 30 '13 at 10:47
    
That's odd that you have to click out and into the folder. Do you have to do that prior to or after you trigger the shortcut? In any case, for Finder to recognize the change, it has to be restarted, when that happens, I simply use the ⌘ + TAB key to get back to the Finder window if needed. –  Sly Raskal Dec 30 '13 at 14:48
2  
I have found in 10.9x the finder does not have to be restarted. you can just change the views to something else and back again see my answer here stackoverflow.com/a/21790997/261305 –  markhunte Feb 28 at 12:34
    
Thanks for the tip @markhunte. I didn't know about that workaround, and a good one too! Now I need to adjust my scripts so that it simply refreshes the view rather than killing Finder. Thanks again. –  Sly Raskal Mar 5 at 19:52

The key bindings doesn't work in Column view mode on Maverick, but it works in e.g. List view mode. Switching back to Column view mode after doing the toggle in List view mode then shows the hidden files.

share|improve this answer
1  
This!! This is the answer! +1 thank you. I can't imagine what inspired them to disable it for column mode –  Anentropic Feb 25 at 16:15
    
@Anentropic: I am late in this discussion. I find your answer and works for me, I can see the hidden files but I cannot open them like I could in previous versions. Do you know how to open the hidden files? –  Nrc Jun 16 at 11:03
    
@Nrc if you are in a dialog box for opening a file it is likely the program you are using has specified only certain file types (i.e. file extensions) as suitable to open... hidden files are often unix files beginning with a period and so will be filtered out by most programs unless you select the 'all file types' option... maybe this is your issue? –  Anentropic Jun 16 at 12:01

Never knew that that feature existed. But then, I've always used a different way, one that still works in 10.9:

The system extension Default Folder X. It's an old goodie, and still working well.

One of its Advanced options is to hold down Option when choosing Open/Save etc. to show all files, including the hidden ones.

share|improve this answer

It does still work, but it was buggy for me.

I had to change directories and then return to the first folder. Then it displayed hidden files.

It doesn't help to close/reopen the dialog. I'm not sure how widespread the bug is or what the trigger could be (this laptop is less than 48 hours out of the box).

share|improve this answer
    
Same issue here. My laptop is one week old. –  Vitaly Feb 25 at 15:09

The shortcut ⌘⇧. still works fine for me in Mavericks. It doesn't seem to have been changed since previous versions of OS X.

Some things you can try…

  • Make sure that the folder you're looking at has hidden files/folders.

    • You can use ls in Terminal to see if there are hidden files/folders:

      cd /path/to/folder && ls -la
      
  • Make sure you've not remapped the shortcut to something else.

    • Check System PreferencesKeyboardShortcuts for any mappings to ⌘⇧.
    • Check any 3rd party apps for mappings to ⌘⇧.
share|improve this answer
    
Did you upgrade or a fresh install? Do you have any other script/hook things installed? –  JBRWilkinson Jan 18 at 15:56

As many others said, it still works perfectly fine. Maybe you changed a shortcut to this and that masks your intended task which is to show the hidden files.

share|improve this answer

You can turn it on by default doing this Terminal command:

defaults write com.apple.finder AppleShowAllFiles -boolean true
killall Finder

...but this is less than convenient compared to a keyboard shortcut... but you could create an Automator workflow which runs a service which runs a Terminal command all assigned to a System Preferences Keyboard Shortcut... but still not as convenient.

share|improve this answer
    
downvoters please leave a comment –  JBRWilkinson Dec 30 '13 at 11:24

protected by Community 18 hours ago

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.