Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All of a sudden, dragging a space in spaces to switch it for another space lags and takes for ever.

Why? any solutions? It didn't happen before.

There are not many apps open, memory's fine, dragging windows in Spaces works great, switching into and out of spaces works fast too.

Video example:

PS: embedding videos here would be nice wouldn't it?

share|improve this question
Is that video Realtime? Did you restart your computer? – Martín Marconcini Apr 3 '11 at 20:38
Have almost the same here - '13 MBP 7,1 with 10.6.7 and 8GB ram. What are your specs/versions? – mspasov Apr 3 '11 at 20:41
@Martín yes, it's real time, and has been happening for many days, so yes, restarted many times. (joé chaval!) – Petruza Apr 3 '11 at 21:06
@mspasov 13' MacBook, 10.6.6 OS, 2GB Ram, 2.226 Ghz Core 2 Duo. PS: 10.6.7 is out already? gonna update – Petruza Apr 3 '11 at 21:08
@Petruza This is certainly something I have never seen before, does this happen under any user? Have you tried creating a different user and using spaces from there to see if it exhibits the same lag? – Martín Marconcini Apr 4 '11 at 0:33

Mine is slow too. Note that it works with the mouse, not the graphic, so you can click, drag, release, and move out of Spaces, and the effect will have worked, even if the graphics didn't finish yet.

Also, dragging an empty space is, for me, much faster, so if I want to swap an active work space with an empty one, it is better to drag the empty to the active than the active to the empty.

share|improve this answer
Well, the problem is that I can't move out of spaces ( neither with a key shortcut or a screen corner ) until the slow animation finishes. And in my case even dragging one empty space on top of another empty space is as slow as any other case, so, no workaround :( – Petruza Apr 25 '11 at 14:18
up vote 0 down vote accepted

I reinstalled the OS and the problem went away.
I'll mark this answer as correct until someone comes with a better one.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.