Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Just got my first Mac and am loving it except for the extremely annoying fact that fonts get messed up on my secondary monitor.

The strange thing is that when I drag a window over from my laptop monitor, the fonts look fine on the secondary monitor until I finish dragging, then they get all messed up... some kind of driver issue?

Here's some samples. In both images the left hand side shows how the image looks on my secondary monitor while it's in the process of being dragged over from my laptop monitor, and the right hand side shows how it looks after I drop it:

Any ideas what the hell is going on here? I've tried changing the font smoothing with defaults write -g AppleFontSmoothing -int <1-3>, no dice.

share|improve this question
    
What type of secondary monitor do you have? An official Apple display? Or a non-Apple display. I hate they way Apple punishes the use of non-Apple products. –  JakeGould Dec 1 '13 at 20:09
    
Update: setting the font smoothing to a higher setting (6 seems to work... most resources I've read don't give any indication that it goes higher than 3...) assuages the problem significantly (at least in Chrome, it makes no difference to the Terminal), but the issue is still present on e.g. the Related links on the right hand side of this page. Setting the smoothing any higher doesn't seem to help. –  Benjamin Good Dec 1 '13 at 20:18
    
@JakeGould It's a non-Apple display. –  Benjamin Good Dec 1 '13 at 20:18
    
New comparison image, you can see the right hand font is stretched vertically slightly: i.imgur.com/Fxvob2D.png –  Benjamin Good Dec 1 '13 at 20:34
    
I guess the problem here is that OS X renders fonts differently for secondary displays... but here the usual rendering looks far better... so how do I make it not do that? –  Benjamin Good Dec 1 '13 at 20:45
show 1 more comment

1 Answer 1

You're moving from a retina display to a non-retina display, which changes how things are rendered.

If you didn't have this issue pre-Mavericks, it might have to do with the new "Displays have separate Spaces" setting. Try disabling this in System Preferences => Mission Control.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.