Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a 27" last gen iMac.

I bought a two Jabra headsets to use them with softphone clients.

They don't work on my Mac (OS X Mavericks 10.9). I can hear audio (although not that well), but I can't use the MIC to send audio (on the other side they get A LOT {almost can't distinguish anything} of noise).

I ruled out the following:

  1. I thought both headsets were defective (they're not). They work on a PC.
  2. I thought it was a problem with my softphone client. It's not. I tried three different softphone clients. I even tried with SKYPE's test call with the exact same result: I can hear, but I can't speak (lot of noise).
  3. I thought it was a problem with my iMac USB port. It's not. I tried in all of them and I get the same result.
  4. Finally, I thought it was a problem with all USB ports. It's not. I tried on the same Mac, running Windows 7 with VMWare Fusion, and it works perfectly.

So, it's definitely a thing with Mac OS X. Haven't tried in other Mac or previous OS X versions.

How can I detect what's wrong with it? They're supposed to support Mac OS X. It says so on their WebSite.

Thanks!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.