Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have the following setup and am attempting the use Migration Assistant over Ethernet:

  • Source machine: Early 2009 24-inch iMac running OS X 10.9
  • Destination machine: Latest MacBook Pro Retina running OS X 10.9
  • Connection: direct Ethernet cable between machines

When I use Migration assistant following Apple's documentation I pass through the confirmation code step on both machines, and then get as far as the "Checking Source Machine" screen on the destination, and am stuck there for about 10 minutes, at which point the destination machine jumps back to the language selection setup page, and the source machine says "This machine is attempting to reconnect to your other Mac".

At this point I'm at a dead end: Attempting to proceed through the setup again on the destination gets me nowhere, and the only option on the source machine is "Cancel Transfer", which quits Migration Assistant there and ends the whole process.

On the source machine I've turned off LittleSnitch, which I normally have running, turned off Apple's firewall, and enabled file sharing.

What am I missing? Are there other settings somewhere that I need to check? I've also tried using FireWire to connect my machines, but have a different set of issues there.

share|improve this question
I reproduce the same problem on a migration attempt: MacOS X 10.9 → MacOS X 10.10 above a direct Ethernet cable connexion without any other network interface on (no Wi-Fi, no Bluetooth…). – daniel Azuelos Jan 27 at 23:33

2 Answers 2

I have the same setup except my iMac sports Thunderbolt. I had the same problem and never solved it, but I did find the following work-around helpful:

Place the iMac in Target Mode by going to Apple|System Preferences|Startup Disk, make sure your startup disk is highlighted, select Target Disk Mode and confirm. Connect the computers by Firewire or Thunderbolt (TDM does not support Ethernet). Start Migration Assistant on the MacBook Pro, allow it to change your system, and select the iMac's startup disk.

From there it is easy sailing - choose what you want and how to handle the user accounts and you are home and dry! Don't forget to eject all connected iMac drives before unplugging the cables.

share|improve this answer

Here are the points which don't block Migration Assistant on the source Mac side:

Firewall on

File Sharing off

FileVault on

Here are 2 key points which blocks the reachability of Migration Assistant on the source Mac side:


IPv6 off

This isn't the default configuration. But within enterprise large networks it is a usefull practice to avoid IPv6 problems when your infrastructure and your other computers don't manage it yet.

If IPv6 is off on the source Mac, just turn it on before firing the installation process from the target Mac.

Firewall setting

If your firewall setting on the source Mac is set so that it won't automatically accept connection from signed software (as in this screen capture)

Firewall setting then "Migration Assistant" will fail (the connection will fail, and the source Mac won't display the code to confirm it is the right source).

You just have to turn this switch on before firing the installation process from the target Mac. Of course, this setting won't be correctly transfered by the Migration Assistant since it would block it.

Beware if you want to make different tests!

Once the source Mac has been seen on the network (or direct connection) any configuration change on the source side won't be seen on the target side.

To see any configuration change of the source side the installation process of the target side must be restarted at the boot step from disk.

The back button isn't sufficient.

The Migration Assistant on the source Mac can detect this failure factor and could warn us that it will fail with a clear warning window rather than to play with the rotating gearing.

share|improve this answer

protected by Community Feb 3 '14 at 14:40

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.