Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've just been trying to create a .crt file, so I can copy the contents (text) from a web page in to it, but Mac OS doesn't seem to want to let me do it easily.

Normally in Windows I would right click > new file, or even open notepad and save as (as it lets you save with any extension), but TextEdit in mac forces me to save as RTF, and I seem to be unable to rename it in finder afterwards?!

I ended up opening the terminal and executing touch cert.crt just to create the file. I need to explain this process to some other users - there must be a simpler way.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I tried to recreate your Problem and noticed that you probably have not enabled the "Show all File Extensions" option in the Finder Preferences.

You can check by selecting the Finder and selecting "Preferences" from the Menubar. A small window should appear, titled "Finder Preferences". Select the "Advanced" Icon at the Top of that window. You should now see the option "Show all File Extensions", it should be checked. All files in your finder window should now show their extensions, like .txt or in your case .crt

You can now easily change all files to another extension.

If that does not work then the Fileextension is probably linked to another application. .crt-Files should link to the Keychain-Application which handels all certificates. You can check by selecting the crt-File and pressing "command" + "i". An information window should appear with additional information to that file. At the Entry "open with" should appear "Keychain.app".

share|improve this answer
    
There is no reason for that option to ever be off - always show file extensions. I turn it on on every computer I use for more than 5 minutes. –  CajunLuke Mar 31 '11 at 14:03
    
There's plenty of reason for it to be off. File Extensions don't matter nearly as often as you think they do. It's funny that on Windows I always always ALWAYS enabled extensions (and I think that's more due to .scr/.pif/.exe/.com security than anything), but I love not having extensions in OSX. The icon, file type, and other details are descriptive enough to tell me what to expect when I open it. –  Jason Salaz Mar 31 '11 at 18:07

@J.C.'s answer is good advice, and will let you change the file extension, but it'll still be in RTF format and will not be useable as a certificate file. To solve this, convert the document to plain text in TextEdit before saving it (Format menu > Make Plain Text). When TextEdit has the document in plain text mode, it'll display in a monospace font, and the format bar will vanish from the window. Most importantly, it'll now default to saving with a .txt extension but let you change that in the save dialog. In the save dialog, there'll be a checkbox labelled "If no extension is provided, use '.txt'." -- with that box selected, if you try to save as .crt it'll object but give you a "Use .crt" option; with it deselected, it won't even object.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.