Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use hot corners to lock my screen.

Sometimes, my login window appears but the screen behind it does not turn black. My desktop stays visible, but behind the Login window.

Why is this? Is there any way to fix it?

share|improve this question
    
Do you set Automatic Login on or off? –  Am1rr3zA Apr 1 '11 at 2:36
    
Off. If I recall cOrrectly. –  Moshe Apr 1 '11 at 9:10
    
I haven't seen this occur with recent versions of Mac OS X 10.6.x (Snow Leopard). What version are you using? –  Gary W. Longsine Apr 11 '11 at 2:52
    
@GaryW.Longsine I'm on a MacBook, running Snow Leopard 10.6.6 –  Moshe Apr 11 '11 at 4:04
    
I have seen this too on my Snow Leopard and if I click Cancel on the login dialog, I can access desktop normally. –  Mikko Tapionlinna May 13 '11 at 8:23

1 Answer 1

up vote 2 down vote accepted

I assume that you've selected "Start Screen Saver" in the hot-corner in question, correct?

If so, what screen saver do you currently have configured?

The reason that I ask is that some screen savers (although none of the ones that come with your Mac) start with the current desktop image and then apply special effects to it over time. So I can imagine if..

  1. you've configured your screensaver to shuffle through screen savers, and
  2. you have installed one of the aforementioned screensavers,

...that this combination could produce the kind of symptoms you are describing.

Edit: Interesting. I don't even have "Lock Screen" as one of the choices on my machine:

enter image description here


Edit 2: I had never tried that option until now. I set up my laptop (model identifier MacBookPro5,2, 2.93 Ghz) as you described and put the display to sleep with that hot corner and woke it up over & over again. I went through about 50 iterations, and I was able to reproduce your problem 3 times in that span: the display would appear to blank, but when it woke up I could see my desktop with the login panel overlayed.

Because this kind of configuration involves invoking the special power-management circuitry in the machine, there are more moving parts that can go wrong in the process. I believe you have little choice other than to report the problem to Apple, and even if there is a real bug, there will be a chance that the bug is in the power-management circuitry itself and the 'fix' might only come when you can buy a new machine. Or not. Maybe you could get lucky and there this could be fixed by a firmware update or a point-release of the OS.

I like this option, now that you have pointed it out to me. I like that it immediately puts the display to sleep, which makes me feel better about how my battery is being used. Alas, if blanking the screen and keeping it from prying eyes is a higher priority, maybe you should use the "Start Screen Saver" option instead, and set the screensaver to something mostly black like the "Computer Name" screensaver.

I wish I could offer more help.

share|improve this answer
    
Actually, I am not using a screen saver hot corner. I have (clockwise from top left) Reveal Desktop, Exposé, Spaces, Lock screen. –  Moshe Apr 11 '11 at 15:44
    
I don't even have "Lock Screen" as an option. (See screenshot above.) Where did you set it? –  pohl Apr 11 '11 at 15:48
    
Put Display to sleep. Then I have my computer set to lock on wake-up, so that it requires a password. –  Moshe Apr 11 '11 at 16:32
    
My last comment was too long so I edited my answer above. –  pohl Apr 11 '11 at 16:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.