Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'd like to disable every kind of text anti-aliasing and font smoothing globally in OS X.

With OS X 10.8 on a mid-2013 MacBook Air 13", I've tried quite a few options: the Turn off text smoothing for font sizesand smaller, which corresponds to AppleAntiAliasingThreshold in NSGlobalDomain, doesn't seem to cause any effect — I've tried setting it to 12 through the interface, and to 24 through defaults, to no effect.

defaults read | fgrep Smooth returns nothing, but manually setting AppleFontSmoothing -int 0 or AppleSmoothFixedFontsSizeThreshold -int 24, for NSGlobalDomain, as per http://stackoverflow.com/questions/11660895/disable-anti-aliasing-fonts-in-xcode-4-4-in-mountain-lion, doesn't seem to cause any effect, either.

For example, with Terminal, if I go to preferences, in Settings, Text, Text, there's an option Antialias text, and it's ticked, and there's no way to untick it, because the whole option is greyed out.

How do I completely disable antialias in Terminal and globally for all apps?

share|improve this question

1 Answer 1

defaults write -g AppleFontSmoothing -int 0 should just disable subpixel rendering, like unchecking "Use LCD font smoothing when available" from the General preference pane. It only has effect after you quit and reopen applications.

Terminal does allow disabling antialiasing for some fonts like Monaco, but not for others like Menlo:

iTerm 2 allows disabling anti-aliasing for all fonts.

The "Turn off text smoothing for font sizes ... and smaller" setting has always affected only a small part of all UI elements. On my 10.8 VM, it affects text views in TextEdit, web views in Safari, and the names of files in Finder. The setting was removed from System Preferences in 10.9. defaults write -g AppleSmoothFixedFontsSizeThreshold -int still works in 10.9, but it affects an even smaller subset of all UI elements.

If you think text looks too blurry or bold by default, you can change to a lighter text rendering style by running defaults write -g AppleFontSmoothing -int 1 and quitting and reopening applications. It doesn't disable antialiasing or subpixel rendering though.

share|improve this answer
    
Oh, yes, I see I had "Menlo" selected instead of "Monaco"; after selecting Monaco, there's now an option to turn off Antialias text. –  cnst Nov 16 '13 at 9:30
    
So, there's no way to disable antialiasing in OS X? You'd think AppleFontSmoothing set to 0 would actually disable Font Smoothing, but it merely sets it to something like a lower intensity, as per apple.stackexchange.com/a/60065/37893 ? –  cnst Nov 16 '13 at 9:30
1  
Yeah, I don't know any way to disable anti-aliasing globally. Setting AppleFontSmoothing to 0 just disables subpixel rendering, which is called LCD font smoothing by Apple. 0 corresponds to the "Standard - Best for CRT" setting in 10.5 and earlier, 1 corresponds to "Light", 2 corresponds to "Medium - Best for Flat Panel", and 3 corresponds to "Strong". –  ؘؘؘ Nov 16 '13 at 10:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.