Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been getting this error coming up in my system log. Having looked around for an answer, two things came up commonly: a problem with the spotlight database(s), and permissions on those folders.

Well, I played with permissions and even deleted some of the folders in question to see if they would be re-created properly. I think that was a mistake, there were odd side effects, so I tried my best to restore the folders to the way they had been previously.

Also, resetting MDS didn't help much. Most recently the error comes up when Outlook refuses to get my mail properly.

It's also always followed by Quicklook-related errors as well. enter image description here

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

From Apple Support Communities, with some correction:

  • Command-S at startup for Single User Mode
  • Repair the files ystem as indicated on screen using fsck (took three runs)
  • Mount the file system as indicated on screen, /sbin/mount -uw /
  • Go to /Library/Caches and do rm -rf *
  • Go to my home folder /Users/.../Library/Caches and do rm -rf *
  • Remove a Spotlight folder, rm -rf /.Spotlight-V100
  • Go to /var/folders and do rm -rf *
  • Start normally using exit or reboot command as indicated on screen

Be extremely careful with the rm -rf commands! To double-check that you're in the correct directory:

pwd

I hope that helps!

share|improve this answer
    
I have tried a very similar procedure and it wasn't pretty.. I may just do a quick backup and try it tho. Results coming later today. :-) –  Harv Mar 30 '11 at 16:07
1  
Also - I believe single-user mode is cmd+s, not cmd+opt+s. Wonder when that post was written, I seem to remember it used to be +opt way back when... –  Harv Mar 30 '11 at 16:08
    
Well crap. This seems to have worked. I don't know which step I missed last time I tried this, but I can't deny the results. Thank you! –  Harv Mar 31 '11 at 4:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.