Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running into a situation now and then when the Spotlight menu on OS X 10.9 can't be activated. When I click on its magnifying glass icon I receive only an error indication (beep tone) but get no chance to enter any search terms.

This can happen even if no programs have been launched and while the other menu items work as expected.

What causes this behavior and can it be overcome? (I have by now become reliant on Spotlight to open all kinds of documents, etc., so this seeming misbehavior is esp. unfortunate.)

share|improve this question
the answer below doesn't work for me. I suspect Alfred. – changokun Apr 7 '14 at 17:08
up vote 7 down vote accepted

Same thing was happening to me. Tried the keyboard shortcut (cmd+space, or option+cmd+space) and it worked and now seems to work fine even when I click.

share|improve this answer
This worked for me too. I first had to enable the keyboard shortcut via system preferences. However it seems that it is indexing exceptionally slowly, as if for the first time. – user65540 Dec 23 '13 at 18:38
Worked for me too. My spotlight stopped working after flipping back from VMWare. – gnome Mar 2 '14 at 16:07
Damn, doesn't work for me. Beeps if I click the icon or use the shortcut. – graygilmore Sep 5 '14 at 17:22

protected by Community Feb 4 '14 at 23:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.