Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Everytime I turn on my Macbook Pro it makes a start up noise. This is annoying since there is no volume or ability to turn it off. I just don't want the sound to play at all.

How do I disable this startup sound?

share|improve this question

5 Answers 5

up vote 25 down vote accepted

You can use StartSound.PrefPane which basically just sets the volume to 0 when you shutdown and then turns it back up after login.

share|improve this answer
    
I've been using that on my MacBook Pro since I got it, with no issues. Last week I got an iMac and immediately installed StartSound.PrefPane but it doesn't work -- any ideas why? The settings on the two machines are identical (except the iMac has v1.1b3 instead of v1.1b2), but one is silent at startup and the other isn't.... –  Michael Underwood Aug 17 '10 at 19:42
    
@Micheal - That might be a good question by itself? –  Diago Aug 17 '10 at 19:52
    
As far as I know the System startup sound is burned directly into the computer's ROM, so firmware versions and such likely come into play. I'm sort of guessing, though, as that's a level of the system architecture I'm not overly familiar with. –  Scottie Aug 17 '10 at 20:16
1  
doesn't work on my new iMac either. –  Sebastian Good Aug 17 '10 at 20:46
    
The sample itself is in the ROM, but it plays at whatever volume was left when shutting down, so a solution like the mentioned prefpane should work. –  Petruza Jun 7 '11 at 2:13

I haven't noticed that sound on my MacBook Pro for ages, and today I figured out why. The MBP seems to remember 2 sets of volume settings; both for having-no-headphones-plugged-in, and for having-headphones-plugged-in.

I usually have my external speakers plugged in-when I'm at home, and when I'm travelling/way from home obviously I don't. At some point in the past I have turned the volume down to zero when headphones weren't connected, and now when I start the MBP up there's no sound.

You could try this (though it's not particularly practical) - turn the volume on your Mac right down to zero, then restart the computer. I suspect you won't hear the startup-sound. Like I say, not really practical but if the start-up noise annoys you enough, you might just get into the habit of turning the volume down before switching off. :-)

EDIT: Just realised this this point about turning the volume down has already been made in other answers here, so feel free to ignore this!

share|improve this answer

Open Terminal.app and type:

sudo -s

Give the password when asked for then:

cat >/private/etc/rc.shutdown.local
#! /bin/sh /usr/bin/osascript -e 'set volume with output muted'

then press Ctrl-D and type "exit". Next time you'll reboot in silence BUT you'll have to manually reset the sound volume (F10, slider ...) if you want to hear some music again. Theoretically it should be possible to run under /private/etc/rc.local a script to do it ('set volume without output muted') but that seems to behave erratically.

share|improve this answer

For Snow Leopard and earlier machines download and install "StartupSound.prefPane" which will install a preference pane in system settings to allow you to adjust the startup volume and disable the startup sound:

http://www5e.biglobe.ne.jp/~arcana/StartupSound/BETA/index.en.html

Note that the above has mixed results in Lion. For Lion users the following is recommended:

  1. Login as administrator and open a terminal window

  2. Create scriptfile for muting

    sudo nano /path/to/mute-on.sh

  3. Enter this as content, when done press control+O to save and control+X to exit:

    #!/bin/bash
    osascript -e 'set volume with output muted'

  4. Create scriptfile for unmuting

    sudo nano /path/to/mute-off.sh

  5. Enter this as content, when done press control+O to save and control+X to exit:

    #!/bin/bash
    osascript -e 'set volume without output muted'

  6. Make both files executable:

    sudo chmod u+x /path/to/mute-on.sh
    sudo chmod u+x /path/to/mute-off.sh

  7. Check if any hooks already exist (these will be overwritten, so make sure it is OK for you)

    sudo defaults read com.apple.loginwindow LoginHook
    sudo defaults read com.apple.loginwindow LogoutHook

  8. Add hooks for muting

    sudo defaults write com.apple.loginwindow LogoutHook /path/to/mute-on.sh
    sudo defaults write com.apple.loginwindow LoginHook /path/to/mute-off.sh

Notes:

  • /path/to/ is the location of the scripts, I used /Library/Scripts/
  • you can skip the unmuting loginhook (i.e. each logout will silence your machine), but I like it this way because I always have sound available exactly at the volume level I set last time
  • root has to be the owner of the script files - running an editor from command line with sudo is the easiest way to achieve that (otherwise you need to chown)
  • to delete the hooks, use the following:

    sudo defaults delete com.apple.loginwindow LoginHook
    sudo defaults delete com.apple.loginwindow LogoutHook

(source)

share|improve this answer
    
This is a great answer. It doesn't need any 3rd party software/settings to be installed and teaches you a bit about the system, which gives you more control as you can tweak it a bit. I set a low volume with 'set volume 1.5' on login as that's what I usually want, whenever I turn it up for some reason I usually get annoyed that I forgot to turn it down again afterwards (especially after reboot when there's no chance of remembering that I'd turned it up previously). –  jhabbott Oct 7 '13 at 21:57

If you keep your volume off when you shut down your mac/laptop it wont make the sound when you start it up again!

I don't know if this is true but its what my laptop does :)!

Hope this helps!

share|improve this answer
1  
Please don't guess –  Mark Nov 12 '13 at 9:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.