Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Using this guide: http://www.finiteloops.com/weblog/?p=79

I get this error:

500 OOPS: vsftpd: not configured for standalone, must be started from inetd

I am trying to turn on and off LISTEN in the config, but how to either link VSFTPD with INET or XINET or let it start in listen mode?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

The man page for the config file for vsftpd should be of some help. If you set listen=YES in the config file, then vsftpd will be configured to run in standalone mode. It will then not be needed to be run from inetd or xinetd.

However, if you don't wish to run vsftpd in standalone mode, you will have to look at the man pages for launchd and launchctlto figure out how to set upvsftpdto load vialaunchd. Thexinetsystem was replaced withlaunchd` on Snow Leopard.

share|improve this answer
    
<rant>This is really making me miss my Ubuntu setup. I still can't figure out why people say Mac is great for developing, it is pretty, but Ubuntu is so straightforward with it's package management, Mac has all these hacks like homebrew and port to get around it's lack of integrated package management.</rant> –  Amala Mar 28 '11 at 14:22
    
I didn't realize launchd was also a replacement for xinetd. I used lingon and it shows this as the plist: pastebin.com/YwDygW1c It is not disabled, but there is no entry for which port will trigger the call to this program. Is this setup better on homebrew? But I don't have xcode and have no desire to install xcode just for an ftp server. –  Amala Mar 28 '11 at 14:24
    
I gave up on trying to get it working xinetd style and enabled LISTEN. (I had to use lingon to see the name of the config file it was using, i had .config instead of .conf). It is working now. Thanks. –  Amala Mar 28 '11 at 14:30
    
There's a new package manager called: Homebrew, you might want to give it a try. It's easier than MacPorts and Fink: Homebrew: OS X’s Missing Package Manager. –  Patrick May 17 '11 at 9:16
add comment

Have you tried adding listen=yes in your config file?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.