Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Config and issue

I have a late 2011 MBP, running Mac OS X 10.7.5, 2.3 GHz Intel Core i5, with 16GB 1600 MHz DDR3.

I have just updated my firefox 20 to 25, this issue also occurred with v 20.

When I am uploading files, or just general browsing, sometimes I get a few firefox processes which start to use up CPU cycles, consequently my fans start to spin up.

If I quit Firefox, the processes stay active.


Here is what I have done so far:

ps aux|grep firefox

macbook-pro:~ <my user>$ ps aux|grep firefox
<my user>  29061  84.7  0.0  3699392    304   ??  R     7:10am  22:13.43 /Applications/Firefox.app/Contents/MacOS/firefox -psn_0_7837561
<my user>  29063  84.0  0.0  3701448    304   ??  R     7:10am  22:11.08 /Applications/Firefox.app/Contents/MacOS/firefox -psn_0_7837561
<my user>  29060  83.9  0.0  3698344    304   ??  R     7:10am  22:10.60 /Applications/Firefox.app/Contents/MacOS/firefox -psn_0_7837561
<my user>  29068  83.4  0.0  3701448    304   ??  R     7:10am  22:10.83 /Applications/Firefox.app/Contents/MacOS/firefox -psn_0_7837561
<my user>  29161   0.6  0.0  2434892    548 s002  S+    7:39am   0:00.00 grep firefox

top -o cpu

Processes: 119 total, 6 running, 2 stuck, 111 sleeping, 496 threads                                                                                                 08:06:00
Load Avg: 4.37, 4.38, 4.30  CPU usage: 61.74% user, 36.1% sys, 2.23% idle   SharedLibs: 1944K resident, 0B data, 0B linkedit.
MemRegions: 34474 total, 1609M resident, 56M private, 1254M shared. PhysMem: 1943M wired, 3222M active, 1978M inactive, 7143M used, 9239M free.
VM: 316G vsize, 1092M framework vsize, 6367238(0) pageins, 189344(0) pageouts. Networks: packets: 19241649/15G in, 16860749/7587M out.
Disks: 2829594/65G read, 2171245/68G written.

PID    COMMAND      %CPU      TIME     #TH  #WQ  #POR #MREG RPRVT  RSHRD  RSIZE  VPRVT  VSIZE  PGRP  PPID  STATE    UID  FAULTS    COW     MSGSENT     MSGRECV     SYSBSD
29063  firefox      82.2      44:11.02 1/1  0    9    2677  9724K  397M   304K   11M    3615M  28962 1     running  503  85        20      16          8           3
29061  firefox      82.2      44:15.85 1/1  0    9    2675  9252K  397M   304K   10M    3613M  28962 1     running  503  85        36      16          8           3
29068  firefox      81.9      44:10.64 1/1  0    9    2677  11M    397M   304K   13M    3615M  28962 1     running  503  85        17      16          8           3
29060  firefox      81.7      44:09.96 1/1  0    9    2671  9820K  397M   304K   10M    3612M  28962 1     running  503  85        35      16          8           3
29089  top          10.7      05:43.93 1/1  0    49   32    2476K  216K   3180K  18M    2378M  29089 29083 running  0    2238348+  84      227566032+  113774272+  1011116+

I've also opensnooped all the relevant processes. There are no files being accessed.

For example, the following shows nothing:

bash-3.2# opensnoop -p 29063
  UID    PID COMM          FD PATH 

There is nothing of relevance in dmesg.

bash-3.2# cat /var/log/system.log|grep fire yealds:

Nov  7 06:23:10 ff-macbook-pro [0x0-0x779779].org.mozilla.firefox[28962]: FoxyProxy settingsDir: /Users/michaelpeters/Library/Application Support/Firefox/Profiles/w5sjmxcx.default/foxyproxy.xml
Nov  7 07:11:10 ff-macbook-pro firefox[28962]: timed out waiting for helper registration
Nov  7 07:11:35 ff-macbook-pro firefox[28962]: invalid context
Nov  7 07:12:32 ff-macbook-pro firefox[28962]: invalid context
Nov  7 07:37:13 ff-macbook-pro firefox[28962]: invalid context
Nov  7 07:37:25 ff-macbook-pro [0x0-0x779779].org.mozilla.firefox[28962]: NOTE: child process received `Goodbye', closing down

In the past I have just cleaned up the processes with kill -s 9 but it would be nice to know what is going on.

Question

What next steps could I take to help me understand this behaviour? If it looks like a bug I am happy to submit to the mozilla community.


Update:

I have tried safe mode and the behaviour persists, however it is definitely upload processes: When I upload a file to a website, firefox spawns these processes, one per file:

   5134  92.5  0.0  3829668    308   ??  R     6:31pm   6:53.37 /Applications/Firefox.app/Contents/MacOS/firefox -psn_0_135201
   5130  91.7  0.0  3826524    308   ??  R     6:31pm   6:53.18 /Applications/Firefox.app/Contents/MacOS/firefox -psn_0_135201
   5135  89.8  0.0  3831244    308   ??  R     6:31pm   6:52.96 /Applications/Firefox.app/Contents/MacOS/firefox -psn_0_135201

If I close firefox, the processes change from -psn to -foreground as identified below, the new firefox session uses almost no cpu cycles at all.

ps aux|grep fire

   5191  99.9  0.0  3516256    292   ??  R     6:41pm   8:03.21 /Applications/Firefox.app/Contents/MacOS/firefox -foreground
   5184  99.9  0.0  3501868    292   ??  R     6:41pm   8:03.11 /Applications/Firefox.app/Contents/MacOS/firefox -foreground
   5234   0.3  0.8  3466336 138620   ??  S     6:49pm   0:02.43 /Applications/Firefox.app/Contents/MacOS/firefox -psn_0_897243
share|improve this question

2 Answers 2

I have not seen multiple Firefox processes on OS X like you have. Here's a somewhat tedious process to troubleshoot this further. It may be a bad plugin or a corrupt profile.

Start Firefox in Safe Mode so you can confirm if this problem is due to any plugin or extension. If it works fine in Safe Mode, then you would have to go a bit more slowly and disable one at a time to see which one makes a difference.

You can do also use Firefox with a newly created profile. If that makes a difference, then your old profile is corrupt in some way and you could just start using this profile and add your previous extensions one by one (don't forget to copy over bookmarks from the previous profile if you decide to stick with the new one).

You can look at the crashes by going to the about:crashes page (from the address bar) and load an easy-to-read crash report that may point to issues.

Also look at the instructions and information in Firefox uses too many CPU resources - How to fix.

share|improve this answer
    
Thanks for this, I wish I could upvote you twice or thrice +3, it was really bugging me. The issue was a corrupt profile. –  Deesbek Nov 15 '13 at 2:29
    
Sorry same issue still going. –  Deesbek Feb 1 at 10:36
up vote 0 down vote accepted

This is still occurring.

As a work around every time the processes "runs" away I issue the following command, since even if I upload one image, there may be up to ten "rogue" firefox processes:

for i in `ps axu | grep '[f]irefox' | awk '{print $2}'`;do kill -s 9 $i; done 

I tried to get the above done with the cut command but could not get it to work. I have posted a related question here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.