Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a shell script autogen.sh, I run it under my project directory in terminal:

./autogen.sh 

I get error:

Can't exec "glibtoolize": No such file or directory at /usr/local/Cellar/autoconf/2.69/share/autoconf/Autom4te/FileUtils.pm line 345, line 4.

Then, seems it can not find glibtoolize, so I tried to figure out where is my glibtoolize. Eventually, I find it is in this path:

/usr/local/Cellar/libtool/2.4.2/bin/glibtoolize

Then, I get stuck, how to solve my problem after I found my glibtoolize?

share|improve this question

2 Answers 2

Looks like you already have libtool installed via brew but it is not linked so the required symlinks in /usr/local/bin are still missing. To create them,

brew link libtool
share|improve this answer

I had the same problem after adding glibtoolize to the PATH variable it worked.

PATH=$PATH:/usr/local/Cellar/libtool/2.4.2/bin
export PATH
share|improve this answer
    
This just sets the path, which doesn't link anything. –  patrix Oct 27 at 14:46
1  
Also, you do not set a path to a specific file in bash. What you would do is set PATH=$PATH:/usr/local/Cellar/libtool/2.4.2/bin but that is still problematic because that method only sets one path to one thing in $PATH which is not ideal. –  JakeGould Oct 27 at 14:55
    
Ja, that is true, I changed my answer. In any case this solved my problem, as brew somehow did not make glibtoolize globally available. –  Philiiiiiipp Oct 28 at 15:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.