Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm facing a strange problem. When I type +C with the left command key, it does not work anymore. The left command key is working for +V or +X or any others so it's not a hardware problem.

The C key is working too. The right command key is working for +C.

I tried changing keyboard language, adding a shortcut, reset NVRAM, activated/deactivated VoiceOver (tip found on a site) to no avail. I'm on a MacBook Pro with Mavericks.

share|improve this question
4  
Is this in only one app, or all apps? – sdmeyers Nov 4 '13 at 19:32
    
It's on all apps. I created a new user, same problem. – schwcoop Nov 5 '13 at 14:32
    
Same problem here on OS X 10.10.2 with an external wired apple keyboard. – xslittlegrass Mar 11 '15 at 3:14

10 Answers 10

Make sure when you press CMD+C your Edit menu in the top flashes, this indicates it works as expected.

If it doesn't, go to Keyboard settings in System Preferences and:

  • Restore defaults Modifier Keys...,
  • Restore defaults in Shortcuts tab,
  • In App Shortcuts click the + button and test if Keyboard Shortcut input box will react on your combination.

If Edit menu flashes and it behaves as it suppose to work, then:

  • Re-test in different applications just in case.
  • Re-test if works when using contextual menu (without using the shortcut).
  • Re-test alternative combination such as CMD+X for Cut instead.
  • Run Console to see your System log queries if something obvious is happening.
  • Test if the Clipboard works from the terminal via:

    $ echo test | pbcopy
    $ pbpaste
    

    If Paste menu item is no more greyed out, then maybe it's a problem with Paste command.

    If you're advanced user, use dtruss or fs_usage to debug it, for instance:

    $ sudo fs_usage | grep -C4 MyAppWhereCopyDoesntWork
    

    and then notice other apps which appearing exactly when you press the shortcut which potentially you could consider to quit for testing purposes.

  • Disable any recent programs that you run or restart your computer.

  • Disable VoiceOver as suggested here.
  • Force quit the Finder (e.g.: killall -HUP Finder).
  • If still doesn't work, consider rebooting system, especially in Recovery or Safe mode to re-test.
share|improve this answer
    
Adding in the combinations manually worked for all but + Z for some reason. (Yes I am aware there is more to the answer I haven't tried yet; I just thought it was strange.) – FracturedRetina Nov 5 '15 at 19:46
    
Force quitting Finder made + C stop working on the right too. But not any other commands strangely enough. – FracturedRetina Nov 12 '15 at 19:40

It was a weird experience for me, had the same problem. After long unfruitful research through internet, I took MBP to the Genius Bar. Even they tried with networked operating systems like 10.9, 10.8 and others too. Nothing worked, later after long technical discussion they decided it may be an hardware issue (due to shorting, also option button was not working during startup OS switching). After top keyboard cover replacement it worked! Again something unexplainable, yet worked!

share|improve this answer
    
I have the exact same problem. What do you mean by replacing the keyboard cover? Do you mean the plastic keys? – Osama Gamal Sep 20 '15 at 19:39

What has worked for me was force-quitting Finder (basically after trying all what you have suggested yourselves).

share|improve this answer

Thank you for your insights! after clearing the cache, resetting PRAM, repairing disc and permission, nothing. Then it worked for a few minutes. Finally, I decided to use Keyremap4macbook and assigned the fn key to work like left command. It works, so I leave it like that. Problem half solved...

share|improve this answer
  1. Open System preferences
  2. Select Keyboard
  3. Select Shortcuts
  4. Select Restore Defaults
share|improve this answer
  1. Open System Preferences
  2. Select Keyboard
  3. Select Shortcuts
  4. Select Keyboard
  5. Select Move focus to next window
  6. Click on the key combination
  7. Set it to whatever you want
share|improve this answer
1  
what does "Move focus to next window" have to do with this question? – dwightk Apr 2 '14 at 13:43
    
Legend!! I was having a similar problem. Couldn't use Cmd + 1 . just wouldn't work on anything but I only used it the other day, followed your instructions and deselected "Move focus to next window" TADA!!! fixed! thankyou. don't know why you were down voted. Just because it didn't work for you, don't down vote a correct answer. Thanks mate – doz87 Feb 5 '15 at 5:58

I talked to the Apple support and reset my hardware by pressing shift+ctrl+option and the power button at the same time. Then release everything. To restart your computer, just press on the power button again.

It doesn't damage anything and even got back on the internet pages I was on.

share|improve this answer

You might have a wrong keyboard layout set up on your system, i.e. Dvorak keyboard layout. If you switch to the proper layout you might fix the problem.

Go to System Preferences -> Keyboard -> Input Sources. Then click on "+" and add the keyboard layout of your preference.

Note: Dvorak users should know that there are a few types of the keyboard: Dvorak, Dvorak - Left, Dvorak - Right, Dvorak - Qwerty. Each of those acts differently when combination "Command + C" is pressed.

share|improve this answer

In my case, it was because "Command+C" in Input Sources conflicted with "Command+C" of Copy command.

I went "System Preferences -> Keyboard -> Shortcuts -> Input Sources", and found "Select the previous input source" item, then changed it to "Control+C". Then the "Command+C" Copy command worked.

share|improve this answer

I had the same problem, but after one copy command (cmd + c) with the right command key, the left command key started working again!

share|improve this answer
    
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – IconDaemon Mar 24 '15 at 13:21
    
It shall be not a real answer but it is still a solution for The problem, Master. – Matt May 31 '15 at 9:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.